[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Netgear GA311 (RealTek 8169 chipset) PCI network card and fc5



On 28 Sep 2006, at 16:49, Greg Frith wrote:

Hi,

I'm setting up a reasonably old PC with FC5 to use primarily as a test server for web development.  A few days ago i installed FC5 and spent 2 days trying to configure a wireless network card.  Having finally compiled the kernel with the additional drivers for the wireless card i got it up and running and everything was fine.  The box was hidden away in a corner (where my partner couldn't see it) and all was good.  This morning however the hard disk went in the machine, so i had to purchase a new disk and start all over again.

So my present situation:  Not wanting to go through the pane of setting up a wireless card again, i thought I'd save myself a great deal of hassle and put a standard wired ethernet card in.  So i did, a Netgear GA311 which i believe uses the Realtek 8169 chip set.  I'd already checked online and everyone reported this card as working hassle free under fedora.  But not for me.  On boot I see the message:

r8169 device eth0 does not seem to be present, delaying initialisation

I get the same message if i do ifup eth0.  ifconfig -a does not list eth0.

Using the GUI tool Network Manager the device can be seen under hardware.

So the network card not working is the first problem, any thoughts gratefully received.

In order to try and fix this i have downloaded linux drivers from the Realtek site.  To install i need the kernel source, so i also downloaded kernel-devel-2.6.15-1.2054_FC5.i686.rpm.  When i try to install this rpm i get:

-> rpm -Uvh kernel-devel-2.6.15-1.2054_FC5.i686.rpm
error: cannot create %sourcedir /usr/src/redhat/SOURCES.

Any thoughts?

Many thanks, Greg.


Hi all,

A reply to my own message with my final 'solution' in case this is of benefit to anyone else searching the archive with a similar issue.

I borrowed another basic (unbranded) network card with the same RealTek chipset and tried this, it gave me exactly the same error and i was unable to bring up a network connection with it.  Therefore I concluded that there was nothing wrong with the network hardware.

I finally gave in and purchased a new motherboard, processor, memory and PSU.  Having installed these components and booted up on the same hard disk which had the FC5 install from the previous machine the system immediately recognised the network hardware built into the motherboard (again a RealTek chipset) and the network was up.  Being a glutton for punishment, I then installed the original Netgear GA311 card and re-booted.  Again the machine immediately saw the card and had access to the network.

So, an incompatibility either between the network hardware and old motherboard/BIOS or Linux and the old motherboard/BIOS.  Whichever i just wish i hadn't tried to save myself a few £££ in the first place and bought a new machine straight away.  The old motherboard by the way was a Gigabyte GA-7IXE4 with an AMD 751/756 chipset.

HTH.  Greg.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]