[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 -- "yum -y upgrade" forever



robert alan bowman wrote:
   Hi,

(NOTE : I hope this does not come twice !! mailcity cunningly hid my email address!!!)

I am a complete fedora newbie. Last night I installed FC5 on a PC and the first thing I did was to run the "yum -y upgrade" command (as per the Myth(tv)ology instructions I was following) to get my machine uptodate.

Sadly, it went a little strange after doing the 520Mb download. Once it got to applying the downloads, I left the machine over night. Well, come this morning (eight hours later), it still had not finished and appeared to be doing nothing.

The entry with the #'s appearing next to it was "coreutils" (something like 125/525). Well, I opened a new session in the same Konsole window just to log in as root and nose around (not that I knew what I was looking for). When I decide! d that was a bad idea, I accidently closed the session tab which was applying the update!!! Arrrrgh!!!! Opps!!.

Now, when I try "yum -y upgrade" again, I get about six dependency error messages. The first being related to openssh (I can't recall the others, I am not at the machine now).

I tried using yum to install openssh and got the following :
<snip>
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/3] updates ! ; &nb sp; [2/3] extras [3/3]
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package openssh.i386 0:4.3p2-4.1 set to be updated
--> Running transaction check
--> Processing Dependency: openssh = 4.3p2-4 for package:
openssh-clients
--> Processing Dependency: openssh = 4.3p2-4 f! or package: openssh-server
--> Processing Dependency: openssh = 4.3p2-4 for package:
openssh-askpass
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package openssh-clients.i386 0:4.3p2-4.1 set to be updated
---> Package openssh-server.i386 0:4.3p2-4.1 set to be updated
--> Running transaction check
--> Processing Dependency: openssh = 4.3p2-4 for package:
openssh-askpass
--> Finished Dependency Resolution
Error: Missing Dependency: openssh = 4.3p2-4 is needed by package
openssh-askpass
</snip>

What can I do please? Have I screwed things up completely? How, please, do I go about resolving the dependency issue? Any tutorial links to help resolve this problem?

Thanks for helping this complete novice.

Hopefully you still have the downloaded packages in /var/cache/yum/updates/packages

Give this a try:
# cd /var/cache/yum/updates/packages
# rpm -Uvh --replacefiles --replacepkgs openssh*

See if things look a bit better after doing that.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]