[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: network route



On Thu, 2006-10-05 at 01:05 +0930, Tim wrote:
> On Wed, 2006-10-04 at 11:12 -0400, Ric Moore wrote:
> > DNS name                dns.asm.bellsouth.net
> 
> I haven't noticed a "DNS name" doohicky in the network configuration.
> Does it say *that* in yours?  If not, what exactly does it say?
> 
> I see a "DNS search path", that means a suffix to add onto the end of a
> dotless hostname, to subsequently try.  e.g. If you tried to "ping
> test" (i.e. lazy typing) when you had "example.com" in the "DNS search
> path" it'll try pinging "test", or "test.example.com" if it didn't find
> an IP for "test" in your hosts file.
> 
> If you're referring to entering a FQDN for your system, I wouldn't
> expect it to be something with "dns" in the name (typically, something
> like that's the sort of hostname you'd see someone assign to a dedicated
> domain name server).
> 
> I can't quite imagine why you'd be entering a hostname for a DNS server
> belonging to your ISP in your network configuration.

Ok, try this... go into Network Device Control, click on configure,
which will give you another screen. You'll see eth0, it should be blue,
then click on the DNS tab. You'll see:
Primary DNS 	|______________
Secondary DNS 	|______________
Tertiary DNS	|______________
DNS search path	|______________

... the DNS search path is where you put the primary DNS name. Right
now, with DHCP running things, mine has "launchmodem.com" which ties
into dns.asm.bellsouth.net, in the modem's configuration. DHCP entered
that, not me. Both my Primary and Secondary DNS addresses are
192.168.1.254, the DSL modem. All of this works like a charm. If I was
just running a client machine, I'd be tickled pink and would shut up.
<everyone erupts into cheers!> All is good. 

BUT, to have the internet knock on my server's door, and have
www.wayward4now.net resolve correctly, I take the DSL modem out of the
loop by setting it to "passthrough" mode. Now the modem merely dials up
and connects on it's own. It uses PPPoE to the phoneline and accepts a
ethernet connection to my box. My box is supposed to have all of the
static control now. It has in the past. First time I set it up, it
worked like a charm. So, I'm re-installing everything I can find that
has anything to do with networking and DNS. Something has blown up along
the way. I still think I need to set a route, but I didn't do that
before. Thanks for your considerations and your patience. Ric






-- 
================================================
My father, Victor Moore (Vic) used to say:
"There are two Great Sins in the world...
...the Sin of Ignorance, and 
...the Sin of Stupidity.
Only the former may be overcome." R.I.P. Dad.

Linux user# 44256
Sign up at: http://counter.li.org/
http://www.sourceforge.net/projects/oar
http://www.wayward4now.net

================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]