[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: network route



Ric Moore:
>>> DNS name                dns.asm.bellsouth.net

Tim:
>> I haven't noticed a "DNS name" doohicky in the network configuration.
>> Does it say *that* in yours?  If not, what exactly does it say?


Ric Moore
> Ok, try this... go into Network Device Control, click on configure,
> which will give you another screen. You'll see eth0, it should be blue,
> then click on the DNS tab. You'll see:
> Primary DNS 	|______________
> Secondary DNS 	|______________
> Tertiary DNS	|______________
> DNS search path	|______________
> 
> ... the DNS search path is where you put the primary DNS name.

No.

It's where you enter hostname suffixes (domain names) that you'd like
your system to add to a hostname, if queries against that hostname don't
get answered.

i.e. If you put "example.com" in there, and then tried to ping "testme"
your system would try to ping "testme" (presuming that there was a
testme entry in your hosts file or a DNS server could resolve it),
*then* it would try to ping "testme.example.com" (if the first attempt
didn't have an answer).

Now, if for some strange reason, you'd like to just use "mail" and
"news" in your client configuration, instead of "mail.bellsouth.net" and
"news.bellsouth.net" (presuming some common expectable addresses), you
could have put "bellsouth.net" into the DNS search path.

It's also possible to string multiple search paths, see man resolv.conf
for details about the /etc/resolv.conf file.  You don't have to put
anything in it, by the way.  It has no necessary relationship with any
particular domain names (i.e. it doesn't have to be the ISP's), it's a
fall back to try *instead* (if *this* doesn't work, try *that*).

> Right now, with DHCP running things, mine has "launchmodem.com" which
> ties into dns.asm.bellsouth.net, in the modem's configuration. DHCP
> entered that, not me.

Doing a dig launchmodem.com produces no answer.  Doing a whois on it
shows it's owned by Bellsouth.

Sounds like that ISP might be doing something as monumentally dumb as
one of our cable ISPs did:  Telling users to configure their mail
clients to use just "mail" as the server address, news clients to use
just "news", and so on.  Some software balks at using hostnames with no
dots in it, and they never told anyone the fully qualified domain name
addresses to use.

> Both my Primary and Secondary DNS addresses are 192.168.1.254, the DSL
> modem.

Rather pointless.  You may as well just have a primary entry in.  The
idea of primary and secondary servers is that if the primary one doesn't
answer, you query the second one.  If the primary one, in your case,
doesn't have an answer, asking it the same question isn't going to help
you.

> BUT, to have the internet knock on my server's door, and have
> www.wayward4now.net resolve correctly, I take the DSL modem out of the
> loop by setting it to "passthrough" mode. Now the modem merely dials up
> and connects on it's own. It uses PPPoE to the phoneline and accepts a
> ethernet connection to my box. My box is supposed to have all of the
> static control now. It has in the past. First time I set it up, it
> worked like a charm. So, I'm re-installing everything I can find that
> has anything to do with networking and DNS. Something has blown up along
> the way. I still think I need to set a route, but I didn't do that
> before. Thanks for your considerations and your patience. Ric

Have you read the information provided by your ISP, and also quoted by
someone else in this thread?  Although you have a static IP, you are
specifically told, "do not hard code the details, let DHCP configure
things every time."

It's not truly static, they do it that way so that changes can occur
automatically (when they reconfigure things, or if you connect to
different equipment and it has different settings).

What DNS server holds records for wayward4now.net?  If it's a public
one, then it shouldn't matter what you use to try and query records for
it.  Is resolving it the only problem you're trying to fix?

-- 
(Currently running FC4, but testing FC5, if that's important.)

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]