[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problems updating with yum



On Sunday 08 October 2006 21:02, Scott Berry wrote:
> Hello there,
>
> I am having a problem where yum says that there is not a correct baseurl
> for yum.  However I have turned the repo off to see if updates would work
> correctly with no luck.  Does anyone have any idea what is going on here? 
> Also what is the baseurl for this too be?  Here is the log of yum updates:
>
> root localhost:/etc/yum.repos.d
> [root localhhost yum.repos.d]# yum update
> Loading "installonlyn" plugin
> Setting up Update Process
> Setting up repositories
> legacy-updates                                                       [1/8]
> kde-redhat-all                                                       [2/8]
> flash                                                                [3/8]
> kde-redhat                                                           [4/8]
> core                                                                 [5/8]
> jpackage-generic                                                     [6/8]
> Cannot find a valid baseurl for repo: jpackage-generic
> Error: Cannot find a valid baseurl for repo: jpackage-generic
> [root localhost yum.repos.d]#

As Kam has said, there is a problem with the Jpackage repo. the best thing to 
do, is on the CLI as root, edit /etc/yum.repos.d, changing the repo for 
Jpackage to enabled=0, then run yum again.

I don't have this problem as I use Apt, and Apt if it has a problem with a 
repo, just bypasses it. Yum seems to get confused if it can't find a repo, 
and decides to go out to lunch, leaving you waiting forever.

Nigel.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]