[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

fc4 -> fc5 upgrade: SpamAssassin cpan trouble



I have upgraded a mail server from fc4 to fc5
(this has previously been upgraded from fc3, etc.).

Previously, I have installed SpamAssassin from CPAN, but now
I want to install it from rpm.

On my machine, I have:

# fgrep '$VERSION = ' `locate SpamAssassin.pm`
/usr/lib/perl5/site_perl/5.8.0/Mail/SpamAssassin.pm:$VERSION = "2.63";              # update after release
/usr/lib/perl5/site_perl/5.8.6/Mail/SpamAssassin.pm:$VERSION = "3.001000";      # update after release (same format as
perl $])
/usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin.pm:$VERSION = "3.001003";      # update after release (same format as
perl $])

It is currently using 3.001000:

# fgrep SpamAssassin /var/log/maillog
Oct  9 08:54:38 mogens1 amavis[1888]: Module Mail::SpamAssassin  3.001000

I also have:
# ls /usr/lib/perl5/site_perl/
5.6.1  5.8.0  5.8.3  5.8.4  5.8.5  5.8.6  5.8.7  5.8.8  autoupdate

How do I clean up this mess? Can I simply just delete
all 5.x.x folders except 5.8.8 in site_perl?

When I install CPAN modules using the cpan command, how
does it keep track of which modules have been installed?

Mogens

-- 
Mogens Kjaer, Carlsberg A/S, Computer Department
Gamle Carlsberg Vej 10, DK-2500 Valby, Denmark
Phone: +45 33 27 53 25, Fax: +45 33 27 47 08
Email: mk crc dk Homepage: http://www.crc.dk


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]