[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot fails after change of motherboard (using LVM)



On Thu, 2006-10-12 at 12:09 -0400, Volker Englisch wrote:
> I have a problem I'm trying to solve and I'm hoping someone here might 
> know a solution.
> 
> I am running FC4 (with AMD64) and was able to boot the machine without 
> problems until last Friday when I had to change my motherboard.
> Since then it appears that I'm unable to boot because the system can not 
> find my LVM.  I see this error message after grub selected the OS:
>    Red Hat nash version 4.2.15 starting
>       Reading all physical volumes. This may take a while ...
>       No volume groups found
>       Unable to find volume group "VolGroup00"
> and as a result a kernel panic.
> 
> I can start the machine by using the installation disk and boot with 
> 'linux rescue' and then I can see my volume and access the data.
> 
> I have two SATA hard drives with a /boot partition and the volume group 
> on the first one and the second HDD has just regular partitions:
>    Filesystem                       Size   Used  Avail Use%  Mounted on
>    /dev/mapper/VolGroup00-LogVol04   15G   7.2G   6.4G  54%  /var
>    /dev/mapper/VolGroup00-LogVol03   34G    12G    20G  37%  /backup
>    /dev/mapper/VolGroup00-LogVol00   24G   7.9G    15G  35%  /
>    /dev/sda1                         99M    29M    65M  31%  /boot
>    /dev/sdb3                        138G    18G   113G  14%  /free
>    /dev/mapper/VolGroup00-LogVol02   29G   3.4G    24G  13%  /home
>    /dev/sdb2                         46G   1.2G    43G   3%  /home/public
>    /dev/sdb1                         46G   706M    43G   2%  /home/mail
> 
> Here is the content of my grub.conf
>    #boot=/dev/sda
>    default=0
>    timeout=5
>    splashimage=(hd0,0)/grub/splash.xpm.gz
>    hiddenmenu
>    password --md5 $1$n/QZG.cU$Cp6m9OIRXtaldLKLpJUE61
>    title Fedora Core (2.6.17-1.2142_FC4)
>       root (hd0,0)
>       kernel /vmlinuz-2.6.17-1.2142_FC4 ro root=/dev/VolGroup00/LogVol00 
>   rhgb quiet
>       initrd /initrd-2.6.17-1.2142_FC4.img
>    title Fedora Core (2.6.17-1.2141_FC4)
>       root (hd0,0)
>       kernel /vmlinuz-2.6.17-1.2141_FC4 ro root=/dev/VolGroup00/LogVol00 
> rhgb quiet
>       initrd /initrd-2.6.17-1.2141_FC4.img
> 
> I already ran
>    $ grub-install /dev/sda
> but that didn't change anything.
> 
> I'm not even sure if this problem is related to grub or to another 
> process later in the boot sequence.
> 
> Thanks for your help.
> 
> -- 
> Thanks
> 
>      Volker Englisch
> 
> mailto:Volker Englisch us    (h)
> 

Try for changing the harddisk settings in the BIOS, I remember had this
trouble too and I solve this way.


best luck


Teo Fonrouge



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]