[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Installing Fedora 6 prerelease on a USB disk [SOLVED] -> now a GRUB problem !



On Sun, 2006-10-15 at 11:04 +0200, Andrea Mastellone wrote:
> Jim Cornette wrote:
> > Andrea Mastellone wrote:
> > 
> >>
> >> I tried booting FC5 DVD with "linux expert" at the prompt, but the usb
> >> disk is not detected anyway... :(
> > 
> > This link from the Fedora forum shows that it used  to work.
> > http://www.fedoraforum.org/forum/showthread.php?t=19896
> > 
> > See the information bobba99  posted since it is pretty detailed.
> > 
> > Have you scrolled down the list in disk druid in order to make sure the
> > /dev/sda devices are not showing? The usb devices used to be referred to
> > as /dev/sdx entries versus /dev/hdx entries.
> > 
> 
> Yes, and the usb disk was not present. Thank you, Jim, for kind
> suggestions, anyway.
> 
> However, I have solved the problem... in a strange fashion, but it
> works. External disk box was connected by means of a cable with two usb
> connectors to the computer (I guess that one connector is used only to
> supply electrical power). While both the cables were attached, the
> expert mode did not detect the disk. I then tried randomly to detach one
> connector.. and, magically, the disk has been dtected in the expert mode
> ! Evidently, the power requirement of the external disk is so low that
> only one cable is sufficient (infacts it is a 2.5" notebook drive).
> 
> Now, I am coping with other problem. I have obviously created by the
> rescue cd a new initrd image with the usb storage drivers. It is GRUB
> that does not work. When I try to boot from the USB disk, only the word
> GRUB appears on the screen and the systems freezes, albeit I have told
> the Fedora installer to install grub on /dev/sda (and not /dev/hda).
> 
> So, can you suggest me a simple but good manual of grub ? I probably
> have to reconfigure it, but I can do it from a working FC5 on hda... I
> tryed to chroot to the FC6 on usb disk and launched grub-install
> /dev/sda, but this is not the correct way :|
> 
> Thanks in advance,
> 
> Andrea
> 
> 
> 
> -- 
> "Homo sum, nihil humani alienum a me puto." (Terenzio).
> "Il vero io รจ quello che tu sei, non quello che hanno fatto di te." (P.
> Coelho)
> 
Hi
Hi
Maybe

http://www.vigla.eclipse.co.uk/

but it is much easier than this - 

Update 10_8_2006

initrd_usb.gz has been created right at the end of a
> > clean FC5 install to a USB disk in "linux expert" mode.
> > After removing the FC5 DVD
> > Cont/Alt/F2
> > chroot /mnt/sysimage
/sbin/mkinitrd --preload=ehci-hcd --preload=ohci-hcd
--preload=usb-storage \
--preload=scsi_mod --preload=sd_mod /boot/initrd_usb.gz \
2.6.15-1.2054_FC5

> > This USB disk boots successfully on two machines with a bit of
tweaking
> > of grub interactively during the first boot and then changing
grub.conf
> > as required.


Works with FC5 (with kde!!) on a 2G Kingston stick
DataTraveler Elite read and write speeds of up to 24MB/sec. and
14MB/sec.
Very usable !!


John




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]