[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

bttv module refuses to load on FC2 at bootup

I'm still struggling with this problem on FC2.

The first OS I tried the Hauppauge Win TV Express card out on was FC2. I had 
TV images, but no sound. Next I installed the drivers, and viewer on Win XP, 
just to check out that sound and vision were working, and yes they were. Next 
I tried another FC2 instance, and images were ok using xawdwcode, and 
strangely after a while I got sound on some channels.

Then I booted up Kubuntu, and had vision, and sound (only on some channels), 
but after searching through docs found an option for setting automuting of 
sound to "0" . Apparently sound is muted as default for channels with weak 
sound signals. This fixed the sound for all channels. I then booted up FC3, 
and went through the same setting of options in /etc/modprobe.conf, and had 
sound and vision on all channels.

This is were it gets weird. I boot up FC2, and bttv is no longer loaded, 
nothing in /sbin/lsmod for it. /sbin/lspci -v shows the card in 2 parts, the 
audio, and the video part, but strangely the IRQ's have changed. When I first 
installed the card, both audio, and video parts of the card were showing as 
irq10. Admittadly I have been messing with this for a while, and had 
unplugged the machine from the wall skt, as had been suggested in the case of 
some problems. Now I've got the cards audio, and video parts on FC2 showing 
as irq9 for some reason. I can still load bttv manually using modprobe, but 
it won't autoload when booting up.

2 Questions:

1: Can I change the irq's that the card is using without messing with the 
BIOS, as I have about 14 distros that run on this machine, and don't want to 
change BIOS settings?

2: Where do I put modules that I want to be loaded at bootup?  On Debian based 
disros I can put the modules in /etc/modules. With Kubuntu, and on Debian 
Sarge (yesterday), adding "bttv tuner=38 automute=0, and tda9887 port2=0 
pal=I" resulted in the modules being loaded at bootup, and being able to 
watch and hear TV. 

Is there somewhere in FC that I can do something similar, to get modules that 
arn't being autodetected at bootup?

I did try a 3rd instance of FC2 that I've got, that hasn't been booted up 
since the TV card was installed. Booting this Kudzu asks about the the old 
winmodem that I removed to make space for the TV card, and I remove the 
config for it, then Kudzu asks about the TV card, so I let it configure it, 
but the bttv module isn't loaded. /etc/modprobe.conf shows a new line:
alias char-major-81 bttv  , but that's as far as it goes.

I'm getting desperate here, and have already taken a break for a few days, as 
it was doing my head in. A pointer or 2 would be helpfull.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]