[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Installing Fedora 6 prerelease on a USB disk [SOLVED] -> now a GRUB problem !



Doru Georgescu wrote:

>>>> If someone is intrested, I can post the step-by-step
> procedure.

>>> Please post the step-by-step procedure because I have a similar
>>> configuration and I want to install FC5 on the external usb
>> drive. 
>>> Thank you a lot, 
>>> Doru
>>>

Here is it the first version of the procedure... I send this under GPL
license, obviously. Since it is a 0.1 version, any
suggestion/criticism/improvement is welcome.

Andrea

-----------------------------------------------------------------------


Installing Linux on an USB disk

This short howto stems from my experience after having installed Fedora
Core 6
prerelease on a USB disk drive. Some steps are however valid for other
distros.

IMPORTANT: You *must* have a computer that can boot directly from the
usb drive
(check your bios). Get the FC6 CD's or DVD, get your USB drive connected
and start the FC6 installation by typing "linux expert" at the boot prompt.

NOTE: I have an USB box drive with an Y-cable, that is supposed to give the
power to the disk. With both cables attached to the computer, the drive was
not detected in the installation. Miracously, I repeated (randomly) the
installation with only one cable attached and the drive has been detected.
I suppose that my drive requires only one cable to work since it is a 2.5"
(laptop) disk so it does not require much power.

Proceed in the installation as usual, taking care to the following two
steps:

- partitioning: usually you have two disk detected (internal, e.g. hda, and
external USB one, e.g. sda). Be aware to tell to the installer to not
include
the internal drive in the installation, unchecking the internal drive
in the list.

- installing grub: select the box "More advanced option" and then go to
next
window, and check the option that tells grub to install to the USB drive
(sda).
In my configuration, GRUB proposed me to install it on /dev/sda1, that
is wrong
(in the first partition instead of the MBR), perhaps it is a bug of FC6
(or I have a bad memory..., but it should explain why the grub did not
worked for me).

Once the installation is finished, reboot again the system from FC6 CD/DVD
selecting the rescue option (it will enable usb drive support
automatically).
When asked for detecting Fedora installations, it is better to say no
in order to avoid some confusion mounting different systems,
e.g. if you have a FC also in internal drive. Also network support is
generally not required.

When you get the prompt, create a dir where you will mount the root
partition
of the USB drive. So you issue

mkdir /mnt/system
mount /dev/sda1 /mnt/system

and you now have to create a initrd image with the usb drive support.
Without
this the kernel, once booted, cannot mount the root partition. So, issue a

mkinitrd --preload=ehci-hcd --preload=usb-storage --preload=scsi_mod
--preload=sd_mod
/mnt/system/boot/initrd-2.6.18-1.2708.fc6.usb.img 2.6.18-1.2708

where initrd-2.6.18-1.2708.fc6.usb.img is the name of the new initrd
file and 2.6.18-1.2708 is the kernel version, you can check it by
issuing uname -r.

Edit /boot/grub/grub.conf and make sure the entry for the kernel you're
going to
be booting uses the new ...-usb.img file not the original img file.

Reboot the computer off the USB drive and check that everything works.
If the
GRUB hangs showing only the GRUB word, try to reboot the computer again,
sometimes this works since I guess that the BIOS changes the drive mapping.

If the GRUB hangs again (or it does not work at all), reboot the system
from the FC6 DVD (or from your FC system on internal drive, this is the
same).

When you get the prompt (as root if you logged on your linux box on
internal drive),
remove (or rename) /boot/grub/device.map and regenerate it by

grub --device-map=/boot/grub/device.map

In this way, grub will detect the devices attached to the system
(including the
usb drive, that must be attached when launching the command, and mounted
in the root partition)

Exit from grub with "quit", and look at device.map. Take the name
assigned to the usb drive (in my system is (hd1), corresponding to
/dev/sda). Now launch again grub and at the grub prompt give

root (hd1,0)
setup (hd1)
quit

assuming again that the root partition is the first in the usb disk (it
is good
at this stage that you learn some more on grub disk label, try a Google
search !).

Edit the grub.conf in the usb drive (e.g.
/mnt/system/boot/grub/grub.conf ),
and change any hd1 occurrence to hd0, if necessary. This since, when you
will boot the system from the USB disk, it will become the FIRST drive
for grub, whereas the internal drive will be the second...

Now, try to reboot from the USB drive.
It should go fine (again, if the GRUB stucks, try to boot twice). If not...
please contact me (you should have almost the grub shell at this point).



-- 
"Homo sum, nihil humani alienum a me puto." (Terenzio).
"Il vero io รจ quello che tu sei, non quello che hanno fatto di te." (P.
Coelho)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]