[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: bttv module refuses to load on FC2 at bootup



On Monday 16 October 2006 23:31, Peter Reed wrote:
> Nigel Henry wrote:
> > I'm still struggling with this problem on FC2.
> >
> > Nigel.
>
> This may help.  I cannot remember how I had this setup under FC2 I am
> using FC5 now and it is different. Good Luck
> http://www.tldp.org/HOWTO/BTTV/

Hi Peter. Thanks for the link. I have read that before when looking for tuner 
types, but going back to it again has put me on the path to fixing the 
problem.

The problem on FC2, even though it was working ok when I first installed the 
TV card, and tried it with Xawdecode, is to do with IRQs. Initially both 
"video" and "audio" parts of the card shown in lspci were at IRQ 10. Now for 
some puzzling reason they are both at IRQ9.  As suggested in the HOWTO I ran 
xawdecode -hwscan, and miraculously along with the output, the bttv, and 
dependent modules loaded. Also the IRQ of the video part of the card was 
changed to IRQ10, verified in lspci -v.

Next under the "autoloading the modules" paragraph, I just added the line.
pre-install bttv to /etc/modprobe.conf.  On the bootup text this showed up as 
a bad line by modprobe, but starting Xawdecode from it's desktop icon, it 
started ok, and I have TV. I have no idea where this "pre-install" command 
comes from, as it's not in the man pages for modprobe, or modprobe.conf. Be 
that as it may. My /etc/modprobe.conf for the bttv stuff now looks like this.

alias char-major-81 bttv   (added when card was detected by Kudzu)
pre-install bttv   (this appears to run when xawdecode is opened)
options bttv tuner=38   (added by me as tuner is detected as "4". No tuner)
install bttv /sbin/modprobe tda9887 port2=0 pal=I; /sbin/modprobe 
--ignore-install bttv   (this line installs tda9887 with it's options before 
bttv, which is a tip I saw on a forum post specifically for FC2)

Just for info. The "port2=0" option is try if you can't get any sound. this 
works for me. I'm in Northern France, and this fixes the sound for the French 
SECAM channels, and for the Belgian PAL channels.

The "pal=I" option, and that's an upper case "i", fixes the problem of getting 
no sound for the UK channels.

Another option to be added the "options bttv tuner=x" line if you have low 
signal strength on the audio is, "automute=0" . This works on FC3, Kubuntu, 
and Debian Sarge, but not on FC5 for some reason, and I havn't set the option 
on FC2 yet, but expect it to work.  FC5 has Kdetv available, and the config 
file for kdetv in .kde/share/config shows automute as false, but doesn't seem 
to work. I installed Xawtv from Axel's repo on FC5, and the options screen 
when the app is running allows you to change automute to "off". This does 
work.

I have spent more time on these TV card problems than I've ever spent on 
soundcard problems on FC1, Debian, Slackware, and Gentoo combined.

The last thing I'd like to find out about is what I presume is refresh on FC1, 
and FC3. On FC5, Kubuntu, and Debian Sarge there are no problems with the 
images. On FC1, and FC3 I have problems. I don't know the right word, but 
when images move I get sparkly lines left behind before the image stops 
moving. Close ups are worse than long shots. Any hint as to what this is, and 
how to fix it? I may have to start a different thread for this perhaps.

Thanks again Peter for the link to the HOWTO. At least I've got FC2 up and 
running with the TV card.

Nigel.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]