[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with iPod

Hash: SHA1

Ed Smits wrote:
> Running FC5, kernel 2.6.18, all other things work OK. Plug iPod in
> as normal:
> 1) as soon as I mount it Amerok crashes, unmounting my other USB
> drives along with it. The unmount "feature" has been reported to
> Amerok - it automatically unmounts the USB drives whenever it shuts
> down, either intentionally or by crashing.
> 2)  try to use GtkPod to manage the iPod - if the ipod is mounted it
> crashes - segmentation fault, if I mount the iPod with GtkPod
> running it doesn't see it. I did have to change the default location
> in GtkPod from /mnt/ipod to /media/disk.

What, if any, errors are there when gtkpod segfaults?

> The same setup worked on my previous install with 2.6.17. I handled
> my iPod through Amerock, worked like a charm. I'm a newbie so most
> stuff is setup as default.

More details.  You say a previous install, so more has changed than
just the kernel then, correct?  If so, what was your previous install
and what is your current install (versions of Fedora)?  What versions
of amarok, gtkpod, and libgpod do you have?  Did you get them from
Fedora (and Livna for gtkpod) or from another repository?

(The version of libgpod included in Fedora is pretty ancient and many
many bugs have been fixed in more recent versions.  That would be my
first suspect.  I've been using libgpod and gtkpod from CVS forever
now and it works splendidly.  The latest releases of gtkpod and libgpod
are pretty recent, so they might be worth checking out.)

Also, what model of ipod do you have?

- -- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
How am I supposed to hallucinate with all these swirling colors
distracting me?
    -- Lisa Simpson

Version: GnuPG v1.4.5 (GNU/Linux)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]