[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with iPod

I haven't topuched the nano's firmware in a long time, so that
probably isn't the problem. I unistalled gtkpod and libgpod, which
alos uninstalled amerok, and downloaded the latest tar.gz for both
from CVS.

Started with libgpod, ran ./configure, errored out with:

checking for LIBGPOD... configure: error: Package requirements
(glib-2.0 >= 2.4.0 gobject-2.0) were not met:
No package 'glib-2.0' found
No package 'gobject-2.0' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables LIBGPOD_CFLAGS
and LIBGPOD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I'm running glib-1.2.10-18.2.2, so I guess I need to update that, who
knows what that will break. I have no glib at all, so will have to
track that down as well...


On 10/20/06, Todd Zullinger <tmz pobox com> wrote:
I think Jamie was onto something when he asked if iTunes has updated
your ipod firmware recently.  Older versions of libgpod had problems
with a zero length sysinfo file on the ipod.  The latest version
handles is AFAIK.

> as to which versions I have at present:
> libgpod-0.3.0-2.2
> gtkpod-0.99.4-1.lvn5

The latest stable releases are:


I've been using the latest libgpod/gtkpod with my 4th and 5th gen
ipods for ages and they've worked very well together.  (And, oddly, I
had a problem unmounting/ejecting my 5th gen ipod under all the FC5
kernels up until 2.6.18.)

> Where I got them - standard repositories I assume, I don't know
> enough to be grabbing from funky ones. I assume the gtkpod was from
> Livna, could that be a problem?

I don't think so, the folks at Livna do a good job at packaging
things.  But the versions are badly outdated.  libgpod is in core,
amarok is in extras, and gtkpod is from livna.  I don't know what it
would take to get libgpod updated in core.  It appears that the same
ancient version is included in FC6 as well. :(

If Jamie's suggestion about the sysinfo file doesn't help and you try
a 2.6.17 kernel and find it's still not working, I'd suggest trying to
update libgpod/gtkpod.  That's not a fun thing if you've never done
it, but it's very good to know how to do.  I can send you rpm spec
files for those if you want to build packages.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]