[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade FC5->FC6 issues



On 10/25/06, Paul Lemmons <paul lemmons tmcaz com> wrote:

 I am stepping out this time and trying to do the upgrade from FC5 to FC6 using yum upgrade and and having some minor (I hope) issues.

 I have:
 rpm -Uhv \
http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/fedora-release-6-4.noarch.rpm \
http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/fedora-release-notes-6-3.noarch.rpm

And

 rpm -ivh http://rpm.livna.org/livna-release-6.rpm
 To set the environment. When I run yum upgrade I get the following dependency errors:

 Error: Missing Dependency: libsepol - 1.12.27-1 is needed by package libsepol-devel
 Error: Missing Dependency: libgnomecanvaspixbuf.so.1 is needed by package gtkhtml
 Error: Missing Dependency: libttf.so.2 is needed by package VFlib2
 Error: Missing Dependency: libgailutil.so.17 is needed by package compat-gtkhtml3

  Any pointers on what to do to resolve this would be greatly appreciated!


Try using the command:
rpm -q --whatrequires gtkhtml VFlib2 compat-gtkhtml3 libsepol-devel
If it comes up with a list of not-so-important things, then you can
likely yum remove them and then try your upgrade again.

Sometimes packages are not so complete with their "Obsoletes" list and
leave packages hanging around that depend on old libraries that have
updates and this ends up blocking the upgrade.

/Mike


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]