[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

X includes - fc5 x86_64



Hi all,

I am trying to install gnash-0.7.1 (because the lack of flash plugin for 64 bits) in my FC5 x86_64 :

[davila1 kineto gnash-0.7.1]$ uname --all
Linux kineto 2.6.18-1.2200.fc5 #1 SMP Sat Oct 14 16:59:56 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

and got the following error:

[user kineto gnash-0.7.1]$ ./configure --prefix=/home/user/gnash/ checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether make sets $(MAKE)... (cached) yes
checking for pkg-config... yes
checking for kde-config... /usr/bin/kde-config
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for style of include used by make... GNU
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking if C++ programs can be compiled... yes
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for strlcat... no
checking if strlcat needs custom prototype... yes - in libkdefakes
checking for strlcpy... no
checking if strlcpy needs custom prototype... yes - in libkdefakes
checking for main in -lutil... yes
checking for main in -lcompat... no
checking for crypt in -lcrypt... yes
checking for socklen_t... yes
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for inet_ntoa... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for sys/types.h... (cached) yes
checking for stdint.h... (cached) yes
checking sys/bitypes.h usability... yes
checking sys/bitypes.h presence... yes
checking for sys/bitypes.h... yes
checking for poll in -lpoll... no
checking Carbon/Carbon.h usability... no
checking Carbon/Carbon.h presence... no
checking for Carbon/Carbon.h... no
checking CoreAudio/CoreAudio.h usability... no
checking CoreAudio/CoreAudio.h presence... no
checking for CoreAudio/CoreAudio.h... no
checking if res_init needs -lresolv... yes
checking for res_init... yes
checking if res_init needs custom prototype... no
checking for killpg in -lucb... no
checking for int... yes
checking size of int... 4
checking for short... yes
checking size of short... 2
checking for long... yes
checking size of long... 8
checking for char *... yes
checking size of char *... 8
checking for dlopen in -ldl... yes
checking for shl_unload in -ldld... no
checking for size_t... yes
checking size of size_t... 8
checking for unsigned long... yes
checking size of unsigned long... 8
checking sizeof size_t == sizeof unsigned long... yes
checking crt_externs.h usability... no
checking crt_externs.h presence... no
checking for crt_externs.h... no
checking for _NSGetEnviron... no
checking for vsnprintf... yes
checking for snprintf... yes
not using lib directory suffix
checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

Using Yum I searched by :

xorg-x11-devel
libxorg-x11-devel
XFree86-devel

but none of them were found. For instance, I have the following xorg* packages installed in my system:

[davila1 kineto gnash-0.7.1]$ rpm -qa | grep xorg
xorg-x11-drv-elo2300-1.0.0.5-1.2
xorg-x11-drv-i810-1.4.1.3-3.1
xorg-x11-drv-vga-4.0.0.5-2
xorg-x11-drv-aiptek-1.0.0.5-1.2
xorg-x11-drv-tdfx-1.1.1.3-1.3
xorg-x11-drv-spaceorb-1.0.0.5-1.2
xorg-x11-fonts-ISO8859-1-100dpi-7.0-3
xorg-x11-xinit-1.0.1-2.FC5.0
xorg-x11-fonts-100dpi-7.0-3
xorg-x11-drv-vmware-10.11.1.3-1.1
xorg-x11-drv-s3virge-1.8.6.5-1.2
xorg-x11-drv-savage-2.0.2.3-1.2
xorg-x11-drv-dynapro-1.0.0.5-1.2
xorg-x11-drv-sis-0.8.1.3-1.2
xorg-x11-drv-nv-1.2.0-3.fc5
xorg-x11-font-utils-1.0.1-3
xorg-x11-xkb-utils-1.0.1-1.2
xorg-x11-xkbdata-1.0.1-7
xorg-x11-utils-1.0.1-1.2
xorg-x11-drv-siliconmotion-1.3.1.5-1.1
xorg-x11-fonts-misc-7.0-3
xorg-x11-drv-mouse-1.0.4-1
xorg-x11-drv-mga-1.2.1.3-1.2
xorg-x11-drv-fbdev-0.1.0.5-1.2
xorg-x11-drv-s3-0.3.5.5-2
xorg-x11-drv-dummy-0.1.0.5-1.2
xorg-x11-drv-magellan-1.0.0.5-1.2
xorg-x11-drv-via-0.1.33.2-2
xorg-x11-drv-dmc-1.0.0.5-1.2
xorg-x11-drv-evdev-1.0.0.5-1.2
xorg-x11-drv-trident-1.0.1.2-1.2
xorg-x11-fonts-ISO8859-1-75dpi-7.0-3
xorg-x11-drv-fglrx-8.29.6-1.lvn5
xorg-x11-apps-7.0-1
xorg-x11-filesystem-7.0-1
xorg-x11-server-utils-1.0.1-1.2
xorg-x11-fonts-base-7.0-3
xorg-x11-drv-keyboard-1.0.1.3-1.2
xorg-x11-drv-ur98-1.0.0.5-1.2
xorg-x11-drv-jamstudio-1.0.0.5-1.2
xorg-x11-drv-hyperpen-1.0.0.5-1.2
xorg-x11-drv-palmax-1.0.0.5-1.2
xorg-x11-drv-joystick-1.0.0.5-1.2
xorg-x11-drv-digitaledge-1.0.1.3-1.2
xorg-x11-drv-elographics-1.0.0.5-1.2
xorg-x11-drv-summa-1.0.0.5-1.2
xorg-x11-drv-penmount-1.0.0.5-1.2
xorg-x11-drivers-7.0-2
xorg-x11-xauth-1.0.1-1.2
xorg-x11-twm-1.0.1-1.2
xorg-x11-fonts-75dpi-7.0-3
xorg-x11-server-Xorg-1.0.1-9.fc5.5
xorg-x11-drv-ati-6.5.8.0-1
xorg-x11-xfs-1.0.1-4.FC5.0
xorg-x11-fonts-truetype-7.0-3
xorg-x11-drv-vesa-1.0.1.3-1.2
xorg-x11-drv-citron-2.1.5-1
xorg-x11-drv-voodoo-1.0.0.5-1.2
xorg-x11-drv-mutouch-1.0.0.5-1.2
xorg-x11-drv-acecad-1.0.0.5-1.2
xorg-x11-drv-sisusb-0.7.1.3-1.2
xorg-x11-drv-calcomp-1.0.0.5-1.2
xorg-x11-drv-magictouch-1.0.0.5-1.2
xorg-x11-drv-microtouch-1.0.0.5-1.2
xorg-x11-drv-void-1.0.0.5-1.2
xorg-x11-drv-fpit-1.0.0.5-1.2
xorg-x11-fonts-Type1-7.0-3

In case it is not possible to install gnash in FC5 x86_64, then could somebody be so kind to post aome/any tips to downgrade firefox to 32 bits (a real pity I won't be able to enjoy firefox 64 bits) ?

Thanks a lot,

Alberto







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]