[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade FC5->FC6 issues



Rahul Sundaram wrote:
Paul Lemmons wrote:
I am stepping out this time and trying to do the upgrade from FC5 to FC6 using yum upgrade and and having some minor (I hope) issues.

I have:

rpm -Uhv \
http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/fedora-release-6-4.noarch.rpm \ http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/fedora-release-notes-6-3.noarch.rpm
And

rpm -ivh http://rpm.livna.org/livna-release-6.rpm

To set the environment. When I run yum upgrade I get the following dependency errors:

Error: Missing Dependency: libsepol - 1.12.27-1 is needed by package libsepol-devel Error: Missing Dependency: libgnomecanvaspixbuf.so.1 is needed by package gtkhtml
Error: Missing Dependency: libttf.so.2 is needed by package VFlib2
Error: Missing Dependency: libgailutil.so.17 is needed by package compat-gtkhtml3

Any pointers on what to do to resolve this would be greatly appreciated!

You might consider removing all these packages. They are legacy GNOME 1.x stack which is not in FC6. libsepol-devel is not used in FC6 either.

Rahul

I ran into this problem with libsepol also today. I removed the db entry using rpm --justdb --nodeps for libsepol. After removing the database entry, I ran yum install libsepol which pulled in the glibc libraries. Afterwards, yum -y update took care of the rest. (of course I ran from a terminal because the GUI is gonna get killed at some point during the upgrade. It did, But I was at the login screen, so it did not effect me being in runlevel 5) Using a terminal window in the GUI will leave you with about 1000 or so multiple entries in the database. Removing mozilla with yum was also needed on the system which took out yelp and a few other packages which needed mozilla previously. You can add yelp back post upgrade without a lot of trouble.

Previously I thought of yum erase libsepol but it wanted to remove quite a few packages. I decided to do the above instead. I did not have errors when removing VFlib2 with rpm. It is not on FC6, so it will not reinstall. The other two errors listed did not effect my system.

Expect for this to take some time to complete. It took me about 3 hours on guess-timation I copied the DVD rpms over to the hard drive core repository, downloaded the updates and testing repos to their local repositories before upgrading. This was a one shot deal, no re-upgrading needed.


Jim


--
For fast-acting relief, try slowing down.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]