[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade FC5->FC6 issues



Paul Lemmons wrote:

I was really trying hard not to muck with the integrity of the rpm database. I always assume that if I have been a good boy and not mucked with it it knows more than I do.

I checked for libsepol-devel and it was not installed. I then tried to remove libsepol but this was not good. For me, I don't have a problem telling yum and rpm that this package is not installed and then reinstalling the package again. It is still in place, so the program is still there. Overwriting it once again should not extract anything different that what is intended to be installed.


So, I started looking for why libsepol-devel kept reappearing. I ran the "yum upgrade" again and captured the output so I could look at it. (i.e. yum upgrade | tee upgrade.log). I found that libselinux-devel was calling for it. I then yum removed libselinux-devel and all of the problems went away.

Mucking through over 1000 package entries didn't interest me. Since running 'yum install libsepol' pulling more packages in and the update went smooth afterward.

I will muck with the repository when I have to but it is only after a lot of research and determining that it is my only choice.


This is a great way to diagnose the problem and I commend you for your determination. I can't figure out why I had this problem and did not remove libselinux-devel from the system. Why my method worked for me and your resolution worked also is interesting.

Great job on your part!

Jim


--
I waited and waited and when no message came I knew it must be from you.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]