[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NVIDIA kernel module can't be built with dkms - says kernel source is not installed [Solved]



On Mon October 30 2006 1:30 am, Claude Jones wrote:
> On Sun October 29 2006 11:06 pm, Florin Andrei wrote:
> > Claude Jones wrote:
> > > rpm -qa --queryformat
> > > "%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n" | grep kernel
> > > kernel-headers-2.6.18-1.2798.fc6-i386
> > > kernel-devel-2.6.18-1.2798.fc6-i686
> > > kernel-2.6.18-1.2798.fc6-i586
> >
> > https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=211941
>
> Thank you, Florin. I'd stumbled on that link much earlier and
> there very few posts about fixes. Now, there seems to be a
> number of suggested paths. I think I'm going to back up my
> grub.conf and try the rpm -Uvh force method that you used.
> Unlike you, I actually have the correct kernel-devel.
> However, I have the wrong kernel-headers, and, at least on the
> first repo I checked, I couldn't find any kernel-headers
> package BUT the 386 arch - no 586 or 686

To repeat, what worked:
backed up "/boot/grub/grub.conf"
downloaded kernel-2.6.18-1.2798.fc6-i686
ran "rpm -Uvh force kernel-2.6.18-1.2798.fc6-i686"
checked my grub.conf (I didn't have to touch it)
rebooted

That resulted in dkms building my new kernel module during boot-up 
(that's very nice - presumably, in the future, when the kernel is 
updated, dkms will detect that and build the new module 
on-the-fly with no need to wait for the modules to become 
available from the repos); when my system came up, the linux nv 
driver was still loaded, so I ran yumex and removed the NVIDIA 
proprietary driver, rebooted, then re-installed the driver which 
also created a new xorg.conf  to use it; one more reboot, and the 
NVIDIA driver came up and running. 

I still have the 386 kernel-headers package installed - I'll worry 
about that tomorrow. 

Don't know if I would have tried this but for all the others who 
did before me - thanks to all who posted on their experiences in 
solving this. It was a bit disconcerting to run a command that 
replaced the one and only, and running, kernel on my system. 
-- 
Claude Jones
Brunswick, MD, USA


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]