[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

e2fsck: Bad magic number in super-block

I have a HD that refuses to mount with a 'bad magic number in super-block'.

[root moe ~]# mount -t ext3 /dev/hdc /Big-Drive/
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

To get a listing of all the superblocks, I did:

[root moe ~]# mke2fs -n /dev/hdc
mke2fs 1.39 (29-May-2006)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
30539776 inodes, 61049646 blocks
3052482 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
1864 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632,
        4096000, 7962624, 11239424, 20480000, 23887872

Next, I tried:
[root moe ~]# e2fsck -b 32768 /dev/hdc
e2fsck 1.39 (29-May-2006)
e2fsck: Bad magic number in super-block while trying to open /dev/hdc

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

Subsequently I tried the above command and substituted each of the
superblocks listed above with the same results.

Have I missed something? Is there any hope at all for my data?

Thanks for any pointers!


 The Soviet Union does not exist any more in its present format.
  17:35:01 up  3:23,  0 users,  load average: 0.09, 0.15, 0.21

 Linux Registered User #241685  http://counter.li.org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]