[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC-6 post-install update problem



Jim Cromie wrote:
I installed FC-6 yesterday, up from FC-4

the process left me with this, which blocks yum update

$ grep strict rpms-list
selinux-policy-strict-1.27.1-2.27
selinux-policy-strict-2.3.18-10

--> Finished Dependency Resolution
Error: bind-chroot conflicts with selinux-policy-strict < 2.2.0
Error: caching-nameserver conflicts with selinux-policy-strict < 2.2.0
 >

[jimc harpo ~]$ sudo rpm -e selinux-policy-strict-1.27.1-2.27
libsemanage.semanage_direct_remove: Module bootloader was not found.
semodule:  Failed on bootloader!
error: %trigger(selinux-policy-strict-2.4.1-4.noarch) scriptlet failed, exit status 1
[jimc harpo ~]$


also tried yum> clean all, which only slowed down next attempt :-(
and s/\#baseurls/baseurls/' on /etc/yum.repo.d/fedora*
neither helped.

any ideas ?

Try this:
# rpm -e --notriggers selinux-policy-strict-1.27.1-2.27

If you're not trying to use the strict SELinux policy (which doesn't work very well anyway), you might also consider:
# rpm -e --notriggers --allmatches selinux-policy-strict

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]