[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fc5 - kino-8.0 Q?



Dan Dennedy wrote:
Gene Heskett <gene.heskett <at> verizon.net> writes:
PS: I believe this controling utility to be libavc1394, which is installed. Version libavc1394-0.5.1-2.2.

That leaves udev, as in its not automaticly creating the device, and whose name I haven't the foggiest.

Is there a way to "force" the creation of the camera's control device by udev?

The device file is dev/raw1394, handled by the raw1394 kernel module.
 For udev, see linu1394.org/faq.php.

libraw1394 ( libraw1394-1.2.1-1.fc5) is installed, and the modules loaded. But kino-9.2 can't see any of them. Kino-8.02 sees the video stream, but not the control ports of libraw1394. I have also installed the rest of the stuff listed on linux1394.org, including:
libiec61883-1.0.0-10.fc5.2
libiec61883-utils-1.0.0-10.fc5.2
libavc1394-0.5.1-2.2
dvgrab-2.0-1.2.1

I have gone thru the procedure to do the autorelabel of selinux, also to no avail. Besides which its running in permissive mode anyway.

This all worked a year ago last summer on an FC2 install, running kino-7.5, but did require re-enabling the av/c stuff everytime I re-ran kino. It seems every step forward is a step & a half backwards.

I have cinelerra downloading now to see if I have enough stuff to build it. Blender it turns out needs an import function from a camera to be written yet.

I have attached 2 snapshots, one of the full screen (dumb) of kino-8.02 showing its 1394 prefs editing window, and one of just the prefs window of kino-9.2. They won't make it thru the fedora listserver, but I've Cc:'d you also.

What more info can I extract from the system to help troubleshoot this?

Thanks, Dan.

--
Cheers, Gene

PNG image

PNG image


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]