[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum error - "Error in YUM setup" after updating

The other night, I ran YUMEX like normal (FC6, test2). It did its update like normal and updated about twenty packages. On of the packages it said it updated was "yum.noarch 2.9.5-3". After I rebooted, I tried to rum YUMEX and it immediatly popped up with "Error in YUM setup". Once I quit YUMEX, it gives an "Exception occured" and says this: 

Component: yumex
Version: 1.1.2
Summary: TBba6c5a2b __init__.py:554:doUnlock:AttributeError: 'yumexBase' object has no attribute 'conf'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 250, in on_FileQuit
  File "/usr/share/yumex/yumexmain.py", line 654, in delete_event
    self.yumexbase.doUnlock( const.YUM_PID_FILE )
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 554, in doUnlock
    if self.conf.uid != 0:
AttributeError: 'yumexBase' object has no attribute 'conf'

Local variables in innermost frame:
self: <yumex.yumexBase.yumexBase object at 0x9bd0b2c>
lockfile: /var/run/yum.pid

If I type YUM from teh command line, I get this error:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
  File "/usr/share/yum-cli/yummain.py", line 85, in main
  File "/usr/share/yum-cli/cli.py", line 183, in getOptionsConfig
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 123, in doConfigSetup
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 227, in doPluginSetup
    plugin_types, confpath)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 128, in __init__
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 185, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/installonlyn.py", line 23, in ?
    from yum.packages import YumInstalledPackage, comparePoEVR
ImportError: cannot import name comparePoEVR

Any ideas?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]