[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: "Suspend" on Dell Precision M70: ANYBODY have it working in FC5?



Hendrik Strydom wrote:
: On Thu, 2006-08-31 at 11:09 -0700, Dean S. Messing wrote:
: > If so I'd like to hear from you.
: > 
: > I will shortly be installing FC5 on my M70 which I have
: > not been able to effectively use because of lack of Suspend.
: > 
: > I don't care if it is "to disk" or "to memory". As long as I can
: > put the thing to sleep (with  X running) and come back and have
: > all the many things I had going on still going on, I'll be happy.
: > 
: > Thanks for your responses.
: > 
: I have no recent experience with Dell, but do have a Compaq V2000
: (Turion processor, ATI graphics, running X86_64 FC5).  Software suspend
: using acpitool from extras worked well till the fedora kernel got to
: 2.6.17.*, and not since.
: I have confirmed that it works with the newest stock kernel, 2.6.17.11,
: so hopefully it may work again with the next Fedora kernel update.
: FC5 originally shipped with kernel 2.6.15-1.2054_FC5, which could
: suspend on my hardware.  This may not be relevant to your hardware at
: all, but try to suspend before your first update, to eliminate
: regression in the kernel as an issue.  (This will not work if you use a
: respin CD/DVD).
: You probably now this, but it may work better if you do a chvt before
: and after suspending, and you may need specific kernel options.

Thanks Hendrik for the information and suggestions.
I'll try to suspend when I first install, after updating with
everything new except the kernel.

What is a "respin" CD/DVD?  New term for me.

I was unaware of the `chvt' command, though on my Year 2000 Dell
Inspiron 5050 (on which suspend has always worked flawlessly via APM) I
have always had to manually change to a root VT and turn off the network
and PCMCIA adapter before issuing `apm --suspend' to prevent a hanging 
upon `resume'.

I just tried `chvt' on my FC5 desktop and there appears to be a
bug: It takes almost 3 seconds to actually change to a VT, and when I
come back to X, there are a jillion Commandline prompts in the
terminal window in which I executed the command. It was as though my
cat had sat down on the "enter" key.

also `chvt' only appears to work from the root account.

Anyway, I'll keep your suggestions in mind.

Dean


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]