[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: something I don't understand



He will not need to remount /home, but remount /. He is in the single-user maintenance mode.
/etc/fstab is the file he cannot edit.

- Mike

Dean S. Messing wrote:
: Bonjour,
: : As I run short of place on my /home partition, I decided to format a new
: partition on my HD (some place were left) and call it home2 after
: creating it with fdisk. I run
: : mke2fs -j -L home2 /dev/hdax : : then added this line in fstab: : : LABEL=/home2 /home2 ext3 defaults 1 2 : : Then I rebooted the machine.... and, as there was a mistake in the
: fstab, I was dropped to a repair-partition prompt because fsck.ext3
: didn't know what to do with LABEL "/home2"....
: : I thought that there were no problem: I just type the root password and
: tried to comment the bad line in the fstab... Impossible: "the file is
: write protected" was the only answer I got from vi...
: : I was root, the fstab file has write permission for root, but it was
: impossible to modify this file....
: : WHY? : : Thank you. : : PS. I recovered with reformating the partition with the right syntax.

The behaviour is probably due to the parition being mounted "read-only".

>From the commandline, issue `mount' and look at the last item on the
line.  I'm guessing it says "(ro)".  You can change the write mode of
the partition by issuing

   mount -o remount,rw /dev/hda5

assuming /home is on hda5.

Now issue `mount' again and you will see that "(ro)" has changed to "(rw)".

Dean



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]