[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Curious yum problem

Guillermo Garron wrote:

>> I just installed FC-5 on a new disk,
>> and when I tried "yum update" it failed because, it reported,
>> kdebase required htdig .
>> On the other hand, I can update kdebase on other FC-5 systems
>> which I have kept up-to-date.
>> It doesn't particularly matter - I as able to update nearly everything
>> by "yum update [a-j]\*", etc,
>> but I am puzzled why this problem arises,
>> and interested to know if there is a simple way
>> of determining exactly what is looking for what?
>> (It seemed that other packages were looking for htdig.)

> I think i have seen this before,
> some dependencies are not resolved by YUM it just inform you do not
> have it, but do not fetch it.
> What i did in that situations is to *manually* install the required
> package.
> $ yum install htdig
> and then
> $ yum update

Thanks for your response.
I tried your recipe, but unfortunately it did not work.
I found in the end that somewhere along the line
I lost /etc/yum.repos.d/fedora-core.repo ,
goodness knows where or how.

I looked this up on a working FC-5 system,
and found it came with fedora-release-5.5 .
When I downloaded this and ran "rpm --force -ivh fedora-release-5.5"
all was well.

Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]