[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Kernel panic after FC2->FC5



Jack Howarth <howarth <at> bromo.msbb.uc.edu> writes:
>     Today we tried updating an i386 Fedora Core 2
> workstation to Fedora Core 5. The upgrade install
> completed without complaint until we rebooted the
> machine. At that point I got a kernel panic with
> the message...
> 
> Kernel panic - not syncing: Attempted to kill init.

Maybe try booting with selinux=0? You probably have screwed up selinux labels 
due to the upgrade, so you need to relabel before being able to use selinux 
again (running a relabel from the rescue disk could also help). At least that's 
what I ran into when upgrading FC2->FC5 (but I also used selinux=0 during the 
upgrade because it wasn't working without for some reason, probably either bad 
labels or lack of RAM on my hardware, so having screwed up selinux labels was 
to be expected in my case).

Upgrades skipping Fedora releases aren't really well-tested. Rawhide testers 
are usually asked to test upgrades from the previous release only, not from 
earlier ones (nor from test releases, but they do that anyway ;-) ).

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]