[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XSLT extension of php



On Fri, 2006-09-01 at 11:39 +0200, gf durin wrote:

> does anybody know if there is a way to have the xslt extension of php 
> under fedora?
> I need to use it installing the nice tool of biborb 
> (http://biborb.glymn.net/) which enables me to make bib files trough the 
> web.
> I see there are no rpm, and that the request is to recompile php with 
> some options. I found an rpm ( php-xslt-4.3.4-2sls.i586.rpm ) which 
> sounds nice, but it requires php432 (means nothing to me...).
> Can someone suggest me a way?

There are two ways:

   download the src rpm for php and rebuild it with these additional
   compile options: --enable-xslt --with-xslt-sablot --with-sablot-js

   build php-xslt as a php module (*)

Either way you'll need a few prerequisites:

   js and js-devel from fedora-extras

   sablotron and sablotron-devel rpms which you can get from dag/dries
   but you'll need to download the src rpm and rebuild after removing
   '--with-readline' from the build options (and the requirement for
   readline-devel from BuildRequires).

Any other dependencies you should be able to get with yum.

(*) The advantage of building php-xslt as a module is that it will 
work after upgrades to php (mostly) whereas if you build it in to php
you'll have to rebuild each time there's an upgrade.

If you want to try building it as a module let me know and I'll post
some more details.

     
-- 
Ian


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]