[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: "Suspend" on Dell Precision M70: ANYBODY have it working in FC5?



On Fri, 2006-09-01 at 09:49 -0700, Dean S. Messing wrote:
> Hendrik Strydom wrote:
snip
> : On Thu, 2006-08-31 at 11:09 -0700, Dean S. Messing wrote:
> Thanks Hendrik for the information and suggestions.
> I'll try to suspend when I first install, after updating with
> everything new except the kernel.
You may also need to update acpi scripts etc. as recommended for your
hardware for suspend to work when you close the lid etc.  In my case I
use the acpitool package from extras for suspend to RAM.  With this
package a simple acpitool -s (as root) should suspend.  I configure sudo
with no password for this command.

> What is a "respin" CD/DVD?  New term for me.
It is an updated release of the distro which includes all patches up to
the time of the release.  One was released for FC5 by Fedora Unity
(http://fedoraunity.org/) with all patches up to 18 August included.  In
this case it will ship with a 2.6.17 kernel, which does not resume on my
hardware.  (This test may make no difference on your hardware, but it
did enable me to identify the kernel as the culprit in my case.  Without
it I would have been banging my head against the wall by now.)
On my Compaq the noticeable change reported by dmesg on these kernels is

PCI: BIOS Bug: MCFG area at e0000000 is not e820 reserved
PCI: Not using MMCONFIG

The same message is however still reported by the 2.6.17.11 stock
kernel, which does resume properly again.

> I was unaware of the `chvt' command, though on my Year 2000 Dell
> Inspiron 5050 (on which suspend has always worked flawlessly via APM) I
> have always had to manually change to a root VT and turn off the network
> and PCMCIA adapter before issuing `apm --suspend' to prevent a hanging 
> upon `resume'.
> 
> I just tried `chvt' on my FC5 desktop and there appears to be a
> bug: It takes almost 3 seconds to actually change to a VT, and when I
> come back to X, there are a jillion Commandline prompts in the
> terminal window in which I executed the command. It was as though my
> cat had sat down on the "enter" key.
It does much the same on my hardware, but it is useful for automated
suspend if your graphics card does not like being directly suspended.

> also `chvt' only appears to work from the root account.
You can configure sudo to allow the command to run with no password,
which enables user level scripts to suspend.

Regards
  Hendrik



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]