[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem with wake/resume from suspend/sleep/s3 state with ATI Radeon 9600 on Fedora Core FC5



I have an IBM Thinkpad T42 laptop with Fedora Core 5.

It appears to sleep (suspend to RAM; S3) correctly on pressing
the "sleep" function key (Fn F4) and on closing the lid while on
battery power.

It also appears to wake (resume) correctly EXCEPT that the
screen is blank.  I can select a text console (e.g. CTRL-ALT-F2),
login as root, and issue a "shutdown -h now"; of course the
typing is "blind" with nothing showing on the screen.

The video card identifies, under "/sbin/lspci -v", as:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [
Mobility Radeon 9600 M10] (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 0550
        Flags: bus master, fast Back2Back, 66MHz, medium devsel,
latency 66, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
        Memory window 0: e8000000-e9fff000 (prefetchable)
        Memory window 1: c2000000-c3fff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
       16-bit legacy interface ports at 0001

Following is a list of selected rpms currently installed
kernel-2.6.17-1.2174_FC5 (currently booted kernel)
acpid-1.0.4-2
pm-utils-0.15-1
gnome-power-manager-2.14.3-1

I am running only Fedora Core 5 stuff (no ATI proprietary drivers, etc.)
EXCEPT for the MadWifi (Atheros chip) wireless driver necessary to
make the wireless work.  (There do not appear to be well developed
open source drivers for the built in wireless card;  I will switch
when/if they become available.)  This, of course, "taints" the kernel.
I would be willing to run tests of the slip without the Atheros
drivers loaded if someone would provide advice on how to tell FC5
not to load those drivers on boot.

Oldest kernel that happens to be installed on this system is 2.6.15-1.2054_FC5
Under this kernel the sleep button appears to be not operational, however,
the lid switch will cause a sleep when on battery power.  The resume status
is the same, that is, no visible display.

I have tried booting to console mode (run level 2).  However, there appears
to be a bug in the ACPI support such that neither the sleep button nor the
lid switch will sleep the machine in this mode.  (Is there a proper way to
sleep the machine when running in console mode?)

I have attempted searches in Bugzilla for this error.  Unfortunately, it
is difficult to search because of inconsistent terminology.  Is my problem
with "sleep", "suspend", "suspend to RAM", "S3 state", "wake", "resume" or
what?  It is also difficult to know which component is the "affected
component".  This may be a bug in the kernel driver, acpid, pm-utilities, etc.
Unappropriate searches return over a thousand hits.  I have found
some bugs which might be similar, but often there is insufficient
information on the kernel version, video card model, etc. to be sure.

I have tried many of the suggestions made in the bug reports and in
web pages returned by general internet searches.  So far, with out
success.

On another laptop, with a video card identifying as: "Radeon Mobility M7 Lw
[Radeon Mobility 7500]" sleep/wake are operating correctly.

Therefore I have two questions:

-- Has anyone gotten sleep/wake to work with approximately the configuration
   described above (T42 laptop with ATI Technologies Inc RV350
   [Mobility Radeon 9600 M10] and Fedora Core 5 Kernel 2.6.17)?

-- Lacking that, I would be interested in debugging this problem.  I
   prefer to not use the "try this; try that"  method of debugging.
   Rather, I would want to collect information on what is happening
   and derive a solution from that.  I therefore need suggestions on
   what to read to provide the background necessary for this debuggin.
   In particular, I need to read about how the FC5 power management
   is intended to work, and the part which is played by each of
   gnome-power-manager, pm-utils, acpid, video driver (in kernel), hal,
   dbus, and xserver.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]