[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with wake/resume from suspend/sleep/s3 state with ATI Radeon 9600 on Fedora Core FC5



On Wed, Sep 06, 2006 at 03:35:53PM -0300, John DeDourek wrote:
> I have an IBM Thinkpad T42 laptop with Fedora Core 5.
> 
> It appears to sleep (suspend to RAM; S3) correctly on pressing
> the "sleep" function key (Fn F4) and on closing the lid while on
> battery power.
> 
> It also appears to wake (resume) correctly EXCEPT that the
> screen is blank.  I can select a text console (e.g. CTRL-ALT-F2),
> login as root, and issue a "shutdown -h now"; of course the
> typing is "blind" with nothing showing on the screen.
> 

I have an R51 which is similar to what you have
(http://www.charlescurley.com/Lenovo.R51.html), and have observed
similar problems. I'm afraid the only
solution to them I've found is to fall back to the 2.6.16-1.2133_FC5
kernel. Suspend to ram works there. I haven't tried suspend to disk
recently enough on it to remember whether it works on this kernel or
not.

BTW, check to see if your system has the power drain
problem. http://www.thinkwiki.org/wiki/Problem_with_high_power_drain_in_ACPI_sleep

> 
> Following is a list of selected rpms currently installed
> kernel-2.6.17-1.2174_FC5 (currently booted kernel)
> acpid-1.0.4-2
> pm-utils-0.15-1
> gnome-power-manager-2.14.3-1

...

> 
> I have tried booting to console mode (run level 2).  However, there appears
> to be a bug in the ACPI support such that neither the sleep button nor the
> lid switch will sleep the machine in this mode.  (Is there a proper way to
> sleep the machine when running in console mode?)

Sleep control now runs through Gnome, so I'm not surprised it doesn't
work if you boot to level three.

> 
> I have attempted searches in Bugzilla for this error.  Unfortunately, it
> is difficult to search because of inconsistent terminology.  Is my problem
> with "sleep", "suspend", "suspend to RAM", "S3 state", "wake", "resume" or
> what?  It is also difficult to know which component is the "affected
> component".  This may be a bug in the kernel driver, acpid, pm-utilities, 
> etc.
> Unappropriate searches return over a thousand hits.  I have found
> some bugs which might be similar, but often there is insufficient
> information on the kernel version, video card model, etc. to be sure.

Try http://www.thinkwiki.org/

> 
> On another laptop, with a video card identifying as: "Radeon Mobility M7 Lw
> [Radeon Mobility 7500]" sleep/wake are operating correctly.

Hmmm, oddly enough, that sounds like the video card I have, and with
that kernel I have problems.

-- 

Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Attachment: pgp77lEMLYNtM.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]