[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HP accessible from WindowsXP [SOLVED] -- Still solved but ...



On 9/9/06, William Case <billlinux rogers com> wrote:
Hi Jack;

On Thu, 2006-07-09 at 23:59 -0400, Jack Gates wrote:
> On Thursday 07 September 2006 22:30, William Case wrote:
> > Hi All;

> > My printer was named "psc-1310-series---1" -- 19 characters in all.
> >  It wasn't the name I originally gave it.  The name appeared
> > several months ago after I had been experimenting with 'something'.
> >  Probably supplied by kudzu or Anaconda or something else.  It
> > worked, so I left it.  In any case, it is not a name I would
> > choose.  So something in Fedora hasn't read the Samba or Cups
> > manual.
> >
> > It could have been a combination of things, but as soon as I
> > renamed my printer HP-psc-1315 (11 characters), WindowsXP could
> > find my printer.
>
It wasn't the renaming that did it.  The best I can figure is that I had
a test page from an earlier test stuck in the printer memory and when I
did something? to unblock the memory the printer printed a page I
thought was from upstairs.  I now do have the printer working from
WindowsXP to Linux  -- for sure, and it wasn't the length of the name. I
stopped trying to get it to print using the CUPS driver, loaded the
windows HP driver on the upstairs computer and "Bob's your uncle".

But I did uncover something else that is weird, may be a bug and helped
mix everything up.  The help manual for the GNOME Printer Manager says I
can change the name of the queue.  Which I kept doing -- from
"psc-1310-series---1" to "HP-psc-1315" and variations thereof.  As long
as I left FC5 running without logging out, the upstairs WindowsXP
computer could find the new name I had used.

When I logged out and then back in, an additional printer was showing
under the name "psc-1310-series---1" with a different configuration from
the "HP-psc-1315" which had only been a name change.

The "psc-1310-series---1" Queue type: Locally-connected had become
hal:///org/freedesktop/Hal/devices/usb_device_3f0_3f11_CN45PB613FO2_if1_printer_CN45PB613FO2 Custom rather than hp/usb/psc_1310_series_?serial=CN45PB613FO2.  If I pushed rescan the hal line disappeared and the hp/usb/etc. line was left.  Even if deleted the "psc-1310-series---1" again, it showed up as the default printer in some of my applications.  All of these changes were duplicated in the http://localhost:631/ file

Loggout and in again and "psc-1310-series---1" was back.  In fact, it
gets even more confusing to me -- but that is the gist of it.

What's going on?

[snip]

Turn off cups-config-deamon service and see if that helps.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]