[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: stupid dependencies



On Sun, 10 Sep 2006, Martin Marques wrote:


On Sat, 9 Sep 2006 20:08:28 -0400 (EDT), Matthew Saltzman <mjs ces clemson edu> wrote:
On Sat, 9 Sep 2006, Martin Marques wrote:

=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       5 Package(s)

Why does yum want to remove then?

I didn't say you were wrong about yum, I just said I couldn't justify it.
You're right, though--yum want to take evolution-sharp, beagle, and
krb5-auth-dialog as dependencies too, and I don't see what the connection
is via rpm to those either.

Maybe yum's XML package files are corrupt? I thought they got generated with
the rpm definitions.

Here's the problem:

[root endor ~]# rpm -e NetworkManager-glib
error: Failed dependencies:
libnm_glib.so.0 is needed by (installed) evolution-2.6.3-1.fc5.5.i386

bind is needed by NetworkManager which is need by NetworkManager-glib, which is need by evolution. :-(

--
 21:50:04 up 2 days,  9:07,  0 users,  load average: 0.92, 0.37, 0.18
---------------------------------------------------------
Lic. Martín Marqués         |   SELECT 'mmarques' ||
Centro de Telemática        |       '@' || 'unl.edu.ar';
Universidad Nacional        |   DBA, Programador,
    del Litoral             |   Administrador
---------------------------------------------------------

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]