[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem booting new CF card

On Mon, 2006-09-11 at 12:50 -0600, Phil Meyer wrote:
Tod Merley wrote:
On 9/10/06, Phil Meyer <pmeyer themeyerfarm com> wrote:
For temperature, silence, and other conditions, a Compact Flash card is
often used with mini-ATX boards to boot the OS and run the apps from.

On these types of motherboards, the CF card shows up as /dev/hdc

A recent purchase of CF cards however, have been problematic.
Kingston elite pro 2GB 50X CF/2GB-S

These cards are visible and usable to a desktop system running FC5.  No
problem there.  Partitioning, mkfs, and data transfers all were normal
on the desktop box using a USB based card reader.

However, when placed in a system as /dev/hdc and booted, the system
hangs when it first tries to read the partition table from the drive.
Normal operation prints an indented line with the partitions it finds
just after it prints the drive parameters.  ie:
 hdc: hdc1, hdc2, hdc3

With these cards, we get:

And the system is hard hung.  This has been tried with the original and
respin boot CDs.

The fly in the ointment?  KNOPPIX 2.6 kernels boot just fine.  And no,
this project cannot easily migrate to KNOPPIX. :)

What am I missing?  Other CF cards this size have worked in the past.
An old working CF card was booted in this system just to make sure that
the problem is with the new cards.

Stumped ...

I have used various CF cards and some such as SanDisk seem to need ide-nodma added to the grub stanza in order to boot. Otherwise, you get a lockup as you are experiencing. Some brands boot alright with no stanza added to grub.


If you live in a country run by committee, be on the committee.
		-- Graham Summer

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]