[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problems in installing realtek 8139 network card



lspci gives:
/snip
02:05.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
\snip
i.e. only the card configured as eth0
No reference to realtek.

lsmod gives:
8139cp                 25793  0
8139too                29761  0
skge                   39505  0 (this is the driver for eth0)

this is the contents of modprobe.conf:
alias eth0 skge
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0 options snd-intel8x0 index=0 remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias eth1 8139cp

(I did try to alias to 8139too earlier, same result)

PA

Charles Curley wrote:
On Sat, Sep 16, 2006 at 05:19:31PM +0200, Per-Anton Rønning wrote:
Hi,
I have 2 network cards in my FC5 computer, eth0 connects to cable bradband internet and works just fine,
but eth1 seems to be impossible to get up nd running.

There are 2 driver modules for this card on the system, i.e. 8139cp and 8139too, and I have tried both, (not simoultaniously of course) by

Perhaps that's your mistake; see below.

aliasing eth1 to one or the other in /etc/modprobe.conf.
In trying to activate it (running neat) I get this message:
"8139cp device eth1 does not seem to be present, delaying initialization."
In the hardware list in "NEW" (in  neat)I find (and have used)
RealTek RTL8129 Fast Ethernet
Perhaps this is the problem - the hardware spec is too old while the driver spec is correct ..? (the "guide" on the accompanying floppy specifies 8139)
Anyone in the loop on this one?

I have the following (from lspci):

00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139 C+ (rev 10)

This is a built in controller rather than a separate card, but that
should not affect matters.

lsmod shows, among others:

8139too                25409  0
8139cp                 21185  0
mii                     5313  2 8139too,8139cp

I don't know how neat does things. You might try

modprobe 8139too
modprobe 8139cp
lsmod

to make sure everything is being installed.

Then run ifconfig to make sure the NIC shows up.

My modprobe.conf has, in part:

alias eth0 8139too





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]