[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum seems to have crashed my X11 session



I've been running yum logged in graphically and using copy/paste to save the results. I know, the prefered way is to tee yum in a console window, but I'm lazy.

So I left it running just now, and when I came back and tried to bring it back from the screen saver, the screen just remained blank.

I used a virtual terminal to log in and checked if yum was running, and top showed yum about once, but no more.

ps waux | grep yum

showed nothing after that, and redirecting an un-grep-ed to a file showed no yum and seemed not to show as many X11 processes as I remember there should be when one is logged in.

After mucking about a bit and satisfying myself that yum was no longer running, I run a yum list and got no errors. (Got a nice long pause, so I switched to a new virtual terminal, logged in, tried to check that process, switched back, and found the list had completed. After that the cache seems to have taken hold and the yum list command is responsive.)

Has anyone else had X11 just wander away during yum update?

And if yum is not reporting any inconsistencies, is it safe to just proceed now?

Checked yum and xorg logs but don't see anything that looks like a complaint in there. yum.log does show that the screen saver got updated about 10 packages before the end and screensaver's extras got updated about three from the end of the log.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]