[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

re: error can''t find libpam.so.0 etc.



Okay

Since previously sending a message, I rebooted with rescue CD and tried to do /sbin/ldconfig
Not found.
So I did whereis ldconfig, answher $ ldconfig
So I did simply # ldconfig
and got: can''t do , ld.so.conf doesn''t exist
So I made a blank file called ld.so.conf and ran the command and nothing really happened (ld.so.conf remained blank).
I also made a softlink from /lib/libpam.so.0 (yes, it IS ther) to /usr/lib
Then I tried to reboot.
Can''t load file system, gives me a terminal, and then only gives me read access to the filesystem. I''m writing this message without the previous, because, I am on a windows partition, and don''t have access to the previous messages.
I hate using windows....

My first message contained the following:
Help! I canĀ“t even get root to further diagnose or resolve this problem!
(FC5, this after doing a universal update with yumex)

[tony ool-45788232 ~]$ su
su: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory
[tony ool-45788232 ~]$ locate libpam.so.0
/lib/libpam.so.0
/lib/libpam.so.0.81.2
[tony ool-45788232 ~]$ ln -s /lib/libpam.so.0 /usr/lib
ln: creating symbolic link `/usr/lib/libpam.so.0' to `/lib/libpam.so.0': Permission denied
[tony ool-45788232 ~]$ sudo ln -s /lib/libpam.so.0 /usr/lib
sudo: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory

To which, someone replied that I should simply boot to rescue cd and do /sbin/ldconfig (outcome of which I described above).

Please help...I can''t be stuck in this Windows Hell!
I must have my FC5 back!!  I have work to do...

tony

--
--
http://www.baldwinlinguas.com - my translating & interpreting site
http://ww.school-library.net - my education resource site
http://www.photodharma.com - my art & photography
http://www.colourfulpainting.com - my painting contractor business



--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.300 / Virus Database: 268.12.5 - Release Date: 9/18/2006


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]