[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5: High system load when copying data to slow USB media

Boris Glawe wrote:

I have a problem with my 2GB Memory Stick Pro Duo Card. The card itself is an orginal MemoryStick PRO Duo from Sony.

I am using this card in my cell phone. The phone is a Sony Ericsson W810i, which is capable to appear as an usb mass storage device. I also have an USB 2.0 card reader. The problem described below happens with both the card reader and the cell phone.

My problem is, that copying large amounts of data (a few hundred MBs, for example) to that device causes the system load to increase to almost 100% and, under certain circumstances, to lock my desktop from time to time during the copying process. It is normal that copying takes very long, as the card itself is very slow in writing, but the high system load in combination with the lack of responsiveness of the whole system seems to be a bug!?

In addition to this problem, copying data to such a device is very opaque:
A copy command on either the terminal or the nautilus gui, immediately terminates successfully, though the data has not really been written to the card, yet. This asynchronous behaviour is ok for performance issues, but one doesn't know when the card can be unmountet. I actually know what to do: I run the command sync and as soon as this commands terminates, I know that the cache is written to the card. Problem with this: When sync executes, the system load increases even more and the desktop is much more often locked, then it would be without having executed the sync command. The system stabilizes, as soon as the cache is written to the card.

Unounting the card with the Gnome gui make things even stranger. Gnome obviously seems to unmount the card though the cache has not been written yet (the symbol disappears from the desktop), but comes back after about 30-60 seconds with an error message, that the card cannot be unmountet (One usually uses this time to remove the card from the reader) This unmount command triggers a sync, of course, which again results in the same behaviour as described in the paragraph above, when running sync manually. A "df -ah" on the terminal results in a "/media/disk not found" message, then. This is one of the reasons why it would be very nice to at least know, when the device can be unmountet.

Can you confirm the problem with the high system load and the lack of responsiveness when copying large amount of data to a slow USB mass storage device, like my 2GB memory stick pro duo?

Thanks for any hint and comment

greets Boris

The syncing/unmount is a bug and is being worked on.


I had a major problem with a trashed file system on a memory card due to this bug.


On my machine.

$ time { cp *.mp3 /media/music/; sync; }
real    14m35.521s
user    0m0.192s
sys     0m4.500s

160 files

No real load on the rest of the applications.

2Gig ram

Robin Laing

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]