[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenDocument format completly broken!



On Wed, 20 Sep 2006 13:01:21 +0200
"Trond Danielsen" <trond danielsen gmail com> wrote:

> On 9/20/06, Trond Danielsen <trond danielsen gmail com> wrote:
> > I was living under the impression that the OpenDocument format was
> > the savation from incompatible formats, but I was obviously wrong.
> > I have created a odt document in abiword on FC5, and ooffice on
> > both windows and fc5 refuses to open it. Am I the only one in
> > misery, or is this a known problem?
> 
> Ok, the problem has not been solved, but at least I found the reason
> why: Abiword _can not_ save documents in odt format, yet the save menu
> claims so and no error message is given...

Hello, Everyone
Just for the sake of anyone who might look into this to find out what
went wrong for the original poster, I did the following:

1. Since I did not have Abiword installed, I ran "yum install abiword"
Yum installed the following:
Installed: abiword.i386 1:2.4.5-2.fc5
Dependency Installed: enchant.i386 1:1.2.5-2.fc5 goffice.i386
0:0.2.1-1.fc5 gtkmathview.i386 0:0.7.6-3.fc5 libwpd.i386 0:0.8.4-1.2.1
link-grammar.i386 0:4.2.2-1.fc5 mathml-fonts.noarch 0:1.0-21.fc5
ots.i386 0:0.4.2-9.fc5

2. I used the output from "yum install abiword" and created a new
document in Abiword.  I saved it as an ODT document.

3a. I them attempted to open it up in OpenOffice.org (2.0.3)  It opened
up perfectly.

3b. KWord (from KOffice) opened up the document perfectly as well.

3c. I then tried to open it up in the Konqueror web browser.  Konqueror
opened it up in an embedded copy of KWord.  This all worked perfectly
as well.

Also, when I had my home directory opened in Konqueror, I just clicked
on the file in question "abiword.odt" and OpenOffice.org automatically
opened it up.  Abiword itself is on the list of applications to open up
ODT files, but it is way down at the bottom.

In conclusion, on a fully updated FC5 machine running KDE from KDE's
Branch 3.5 (compiled from source), with the Abiword that is currently
in Fedora Extras (version 2.4.5) ODT documents created in Abiword open 
perfectly on OpenOffice.org 2.0.3, Abiword 2.4.5 and KWord 1.6 beta 1.
This is all with no tweaking on my part.  I just did "yum install
abiword" and everything just worked.

Have a Great Day,
Steven P. Ulrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]