[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Kernel later than kernel-2.6.15-1.1833_FC4.i686.rpm SATA broken?



I was running FC4 and I was running fine with 
kernel-2.6.15-1.1833_FC4.i686.rpm.

Then kernel-2.6.16-1.2069_FC4.i686.rpm came out and I upgraded, but my
machine wouldn't boot with it.

Since FC4 has now transitioned to the Fedora legacy project I decided to try
FC5 since the kernel was still kernel-2.6.15-1.2054_FC5.i686.rpm.
So I did an upgrade from FC4 to FC5.
I have found out since that the 2.6.15 kernel is more like 2.6.16.
My machine wouldn't boot with the new FC5 kernel.  I tried the new 2.6.17
kernel and it doesn't work either.

I was able to load the FC4 kernel-2.6.15-1.1833_FC4.i686.rpm and my machine
now boots.

It appears to not be able to find my SATA disks when sata_via.ko loads.

This is what I see when I boot:


Booting 'Fedora Core (2.6.15-1.2054_FC5)' 

root (hd0,0) 
 Filesystem type is ext2fs, partition type 0x83 
kernel /vmlinux-2.6.15-1.2054_FC5 ro root=/dev/V0/L1 acpi=off rhgb quiet 
      [Linux-bzImage, setup=0x1e00, size=0x16eb71] 
initrd /initrd-2.6.15-1.2054_FC5.img 
     [Linux-initrd @ 0x37e3c000, 0x1b312a bytes] 

Uncompressing Linux... Ok, booting the kernel. 
Red Hat nash version 5.0.32 starting 
ata1: failed to set xfermode, disabled 
ata2: failed to set xfermode, disabled 
device-mapper: dm-mirror: Device lookup failure 
device-mapper: reload ioctl failed: No such device or address 

Unable to open /dev/mapper/via_jheaibjjh - unrecognised disk label. 
   Reading all physical volumes.  This may take a while... 
   No volume groups found 
   Unable to find volume group "V0" 
Unable to access resume device (/dev/V0/L0) 
mount: could not find filesystem '/dev/root' 
setuproot: moving /dev failed: No such file or directory 
setuproot: error mounting /proc: No such file or directory 
setuproot: error mounting /sys: No such file or directory 
switchroot: mount failed: No such file or directory 
Kernel panic - not syncing: Attempted to kill init! 



With kernel 2.6.17-1.2187_FC5 the message is pretty much the same except
for:

ata1: failed to set xfermode (err_mask=0x4) 
ata2: failed to set xfermode (err_mask=0x4)


A couple of people have suggested running mkinitrd and I have upgraded it
and created a new initrd file and it does the same thing.

When I boot from the installation DVD in linux rescue mode it load sata_via
And everything is fine.  Just can't boot off the SATA drive.

I would like to be able to use the current kernel.  
I am just not sure how to figure out what broke.  
Is it possible to apply patches to the FC4 kernel to get
from 2.6.15-1.1833_FC4 to 2.6.15-1.2054_FC5?
I could load one at a time until it breaks.
And where would I get those patches?
Other suggestions?

Thanks,
	Jerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]