[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ndiswrapper install problem -



>
>
> I am having a problem getting ndiswrapper to work in this FC5 computer.
>
> uname -a
> Linux box7 2.6.17-1.2187_FC5 #1 Mon Sep 11 01:17:06 EDT 2006 i686 athlon
> i386 GNU/Linux
>
> Shows the kernel as 2.6.17-1.2187_FC5.
>
> and the module I downloaded via yumex
>
> ll /lib/modules/2.6.17-1.2187_FC5/updates/ndiswrapper.ko
>
> However it doesn't work
>
> modprobe ndiswrapper
>
> FATAL: Error inserting ndiswrapper
> (/lib/modules/2.6.17-1.2187_FC5/updates/ndiswrapper.ko): Invalid module
> format
>
> Can someone tell me what I'm doing wrong?
>
> Bob Goodwin


Hi Bob,

I personally have never had luck using ndiswrapper from repos/pre-compiled
packages, no experience on Fedora, but debians never did work. I believe
the problem here would be that the module and the kernel itself have been
compiled by different versions of a (compiler) gcc. I am not 100%, but
pretty sure.

The best way (I think) to solve this, would be to compile your own kernel,
then compile/install ndiswrapper from source. This seems to work best on
this end anyway. Best of luck.  DAN


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]