[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Swap Space Not Being Used?



On Fri, 2006-09-22 at 00:27 -0400, Rick Bilonick wrote:
> I can't get swapon to work and I'm sure swap is off.
> 
> [root ophth-bilora chippy]# free -m
>              total       used       free     shared    buffers
> cached
> Mem:           495        487          7          0         26
> 203
> -/+ buffers/cache:        258        237
> Swap:            0          0          0
> [root ophth-bilora chippy]# /sbin/swapon /dev/hda6
> swapon: /dev/hda6: Invalid argument
> 
> 
> [root ophth-bilora chippy]# cat /etc/fstab
> # This file is edited by fstab-sync - see 'man fstab-sync' for details
> /dev/VolGroup00/LogVol00 /                       ext3    defaults
> 1 1
> LABEL=/boot             /boot                   ext3    defaults
> 1 2
> /dev/devpts             /dev/pts                devpts  gid=5,mode=620
> 0 0
> /dev/shm                /dev/shm                tmpfs   defaults
> 0 0
> /dev/proc               /proc                   proc    defaults
> 0 0
> /dev/sys                /sys                    sysfs   defaults
> 0 0
> LABEL=SWAP-hda6         swap                    swap    defaults
> 0 0
> /dev/hda2               /mnt/windows            ntfs    ro,umask=0222
> 0 0
> /dev/hdb                /media/cdrecorder       auto
> pamconsole,exec,noauto,managed 0 0
> 
> 
> Here is what dmesg shows:
> 
> Kernel command line: ro root=/dev/VolGroup00/LogVol00 rhgb quiet
> resume2=swap:/dev/hda6
> audit(1158897380.741:4): avc:  denied  { unlink } for  pid=1852
> comm="swapon" name="blkid.tab.old" dev=dm-0 ino=1733754
> scontext=system_u:system_r:fsadm_t tcontext=root:object_r:etc_t
> tclass=file
> Unable to find swap-space signature
> Unable to find swap-space signature
> Unable to find swap-space signature
> Unable to find swap-space signature
> Unable to find swap-space signature
> Unable to find swap-space signature
> 
> 
> A few days ago (right before this problem started), I installed
> acpitool
> and I tried to do a suspend (which didn't work). I think that screwed
> something up!
> 
> Rick 
Well clearly swap is not on. But the command to turn it on is: 
swapon -a -e
which should be run by /etc/rc.d/rc.sysinit on boot

-- 
Aaron Konstam <akonstam sbcglobal net>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]