[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problem installing GFS



Is GFS even supported at all on Fedora?  I noticed there is no mention of it at all in the Fedora books.  I think it requires code that is basically unsupported in the Fedora realm.  Can a red hat person clarify this please?
 
thanks
Marc
 


 
On 9/27/06, Imre Gergely <imre gergely astral ro> wrote:

hi

i have some problems installing GFS on a default FC4 installation. here's what
i did:

- installed a FC4 "basic" (custom, all package groups deselected = 700mb)
- did a yum update (with default repository confs)

after this i tried the following:

[root c1 yum.repos.d]# yum install GFS-kernheaders GFS-kernel gnbd-kernel GFS
lvm2-cluster cman-kernel cman-kernheaders cman ccs ccs-devel fence dlm-kernel
dlm-kernheaders dlm dlm-devel magma-plugins
Setting up Install Process
Setting up repositories
updates-released          100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package dlm.i386 0:1.0.0-3 set to be updated
---> Package fence.i386 0:1.32.1-1 set to be updated
---> Package magma-plugins.i386 0:1.0.0-2 set to be updated
---> Package dlm-devel.i386 0:1.0.0-3 set to be updated
---> Package dlm-kernheaders.i686 0:2.6.11.5-20050601.152643.FC4.22 set to be
updated
---> Package ccs-devel.i386 0:1.0.0-1 set to be updated
---> Package GFS-kernel.i686 0:2.6.11.8-20050601.152643.FC4.25 set to be installed
---> Package lvm2-cluster.i386 0:2.01.09-3.0 set to be updated
---> Package cman.i386 0:1.0.0-1 set to be updated
---> Package ccs.i386 0:1.0.0-1 set to be updated
---> Package dlm-kernel.i686 0:2.6.11.5-20050601.152643.FC4.22 set to be installed
---> Package GFS.i386 0:6.1.0-3 set to be updated
---> Package GFS-kernheaders.i686 0:2.6.11.8-20050601.152643.FC4.25 set to be
updated
---> Package gnbd-kernel.i686 0:2.6.11.2-20050420.133124.FC4.58 set to be installed
---> Package cman-kernel.i686 0:2.6.11.5-20050601.152643.FC4.23 set to be installed
---> Package cman-kernheaders.i686 0:2.6.11.5-20050601.152643.FC4.23 set to be
updated
--> Running transaction check
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: dlm-kernel
--> Processing Dependency: magma for package: ccs
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: gnbd-kernel
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: cman-kernel
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: GFS-kernel
--> Processing Dependency: perl(Net::Telnet) for package: fence
--> Processing Dependency: libgulm.so.1.0 for package: lvm2-cluster
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: magma for package: magma-plugins
--> Processing Dependency: libgulm.so.1.0 for package: magma-plugins
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package magma.i386 0:1.0.0-1 set to be updated
---> Package gulm.i386 0:1.0.0-2 set to be updated
---> Package perl-Net-Telnet.noarch 0:3.03-4 set to be updated
--> Running transaction check
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: dlm-kernel
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: cman-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: gnbd-kernel
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: gnbd-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: cman-kernel
--> Processing Dependency: kernel = 2.6.15-1.1833_FC4 for package: GFS-kernel
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: GFS-kernel
Importing Additional filelist information for dependency resolution
--> Processing Dependency: /lib/modules/2.6.15-1.1833_FC4 for package: dlm-kernel
Importing Additional filelist information for dependency resolution
--> Finished Dependency Resolution
Error: Missing Dependency: kernel = 2.6.15-1.1833_FC4 is needed by package
dlm-kernel
Error: Missing Dependency: /lib/modules/2.6.15-1.1833_FC4 is needed by package
cman-kernel
Error: Missing Dependency: kernel = 2.6.15-1.1833_FC4 is needed by package
gnbd-kernel
Error: Missing Dependency: /lib/modules/2.6.15-1.1833_FC4 is needed by package
gnbd-kernel
Error: Missing Dependency: kernel = 2.6.15-1.1833_FC4 is needed by package
cman-kernel
Error: Missing Dependency: kernel = 2.6.15-1.1833_FC4 is needed by package
GFS-kernel
Error: Missing Dependency: /lib/modules/2.6.15-1.1833_FC4 is needed by package
GFS-kernel
Error: Missing Dependency: /lib/modules/2.6.15-1.1833_FC4 is needed by package
dlm-kernel
[root c1 yum.repos.d]#

if seems that the kernel rpm (1833_FC4) cannot be found anywhere. is there some
other (simple) way to install GFS?

thx in advance.

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]