[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Wlan prob - UDP works, ICMP works, TCP doesn't work [long]



Hello List,

I set up FC6 with wlan connection with BCM4318 Chipset. After some probs with wpa_supplicant I finally managed to get it work (as I thought). I also have another box with FC4 as internet gateway (Server) in my local network which has a cabled connection to an access point.

The problem is quite strange:
I can do nslookup from my workstation with the local server as DNS-Server and get a correct answer. I can ping the server. But I can't establich a SSH-Session to the server. It seems that UDP and ICMP works fine so far, but it is impossible to establish a TCP connection. All iptables-chains are set to ACCEPT for the local network (both server and workstation).

Config and proof below.

The AP is configuired to use WPA and WPA2 (PSK), TKIP and AES encryption

Does anyone know a solution?

----------
[root eagle ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
GATEWAY=192.168.100.1
TYPE=wireless
DEVICE=eth0
HWADDR=00:14:c1:0c:8b:6b
BOOTPROTO=static
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=192.168.100.5
DOMAIN=
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=yes
ESSID=Linux
CHANNEL=12
MODE=Managed
RATE=54Mb/s
ESSID=linux

----------
[root eagle ~]# cat /etc/sysconfig/wpa_supplicant
INTERFACES="-ieth0"
DRIVERS="-Dwext"

----------
[root eagle ~]# cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root

network={
       ssid="Linux"
       key_mgmt=WPA-PSK
       psk="<<secret>>"
}

----------
[root eagle ~]# ifconfig eth0
eth0      Link encap:Ethernet  Hardware Adresse 00:14:C1:0C:8B:6B
inet Adresse:192.168.100.5 Bcast:192.168.100.255 Maske:255.255.255.0 inet6 Adresse: fe80::214:c1ff:fe0c:8b6b/64 Gültigkeitsbereich:Verbindung
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:77 errors:0 dropped:0 overruns:0 frame:0
         TX packets:366 errors:0 dropped:0 overruns:0 carrier:0
         Kollisionen:0 Sendewarteschlangenlänge:1000
         RX bytes:10277 (10.0 KiB)  TX bytes:24487 (23.9 KiB)
         Interrupt:11

----------
[root eagle ~]# iwconfig eth0
eth0      IEEE 802.11b/g  ESSID:"Linux"  Nickname:"eagle"
         Mode:Managed  Frequency=2.427 GHz  Access Point: 00:14:C1:03:F9:10
         Bit Rate=11 Mb/s   Tx-Power=18 dBm
         RTS thr:off   Fragment thr:off
Encryption key:D38B-570C-A4F7-FE37-0E81-A4E2-9EE1-D6DB-8BD4-7610-C141-A079-83B5-FF95-35C0-B90A Security mode:open
         Link Quality=100/100  Signal level=3/3  Noise level=183/100
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

----------
[root eagle ~]# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.100.0   *               255.255.255.0   U     0      0        0 eth0
169.254.0.0     *               255.255.0.0     U     0      0        0 eth0
default         linuxserver     0.0.0.0         UG    0      0        0 eth0

----------
[root eagle ~]# nslookup www.redhat.com
Server:         192.168.100.1
Address:        192.168.100.1#53

Non-authoritative answer:
Name:   www.redhat.com
Address: 209.132.177.50

----------
[root eagle ~]# ping -c2 192.168.100.1
PING 192.168.100.1 (192.168.100.1) 56(84) bytes of data.
64 bytes from 192.168.100.1: icmp_seq=1 ttl=64 time=1.14 ms
64 bytes from 192.168.100.1: icmp_seq=2 ttl=64 time=1.10 ms

--- 192.168.100.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 1.105/1.122/1.140/0.037 ms

----------
[root eagle ~]# ntpdate ntp1.ptb.de
4 Jan 22:17:09 ntpdate[2756]: adjust time server 192.53.103.108 offset -0.000217 sec

----------
[root eagle disk]# nmap -P0 -vvvv linuxserver

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2007-01-04 23:01 CET
Initiating ARP Ping Scan against 192.168.100.1 [1 port] at 23:01
The ARP Ping Scan took 0.03s to scan 1 total hosts.
Initiating SYN Stealth Scan against linuxserver (192.168.100.1) [1680 ports] at 23:01
The SYN Stealth Scan took 35.92s to scan 1680 total ports.
Host linuxserver (192.168.100.1) appears to be up ... good.
All 1680 scanned ports on linuxserver (192.168.100.1) are filtered
MAC Address: 00:13:D3:12:D4:5E (Micro-star International CO.)

Nmap finished: 1 IP address (1 host up) scanned in 36.344 seconds
              Raw packets sent: 3361 (147.882KB) | Rcvd: 1 (42B)

----------
[root eagle disk]# dmesg (extract)
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.13
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno linux intel com>
[..]
NET: Registered protocol family 23
bcm43xx driver
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
bcm43xx: Chip ID 0x4318, rev 0x2
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0xd, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x9, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x804, rev 0xc, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x80d, rev 0x7, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 3, Type 2, Revision 7
bcm43xx: Detected Radio: ID: 8205017f (Manuf: 17f Ver: 2050 Rev: 8)
bcm43xx: Radio turned off
bcm43xx: Radio turned off
[..]
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
[..]
SoftMAC: ASSERTION FAILED (0) at: net/ieee80211/softmac/ieee80211softmac_wx.c:306:ieee80211softmac_wx_get_rate()
SoftMAC: empty ratesinfo?
SoftMAC: empty ratesinfo?
ieee80211_crypt: registered algorithm 'WEP'
bcm43xx: set security called, .active_key = 0, .level = 1, .enabled = 1, .encrypt = 1
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Microcode rev 0x123, pl 0x20 (2004-11-16  07:12:11)
bcm43xx: Radio turned on
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1496:bcm43xx_find_lopair()
bcm43xx: WARNING: Writing invalid LOpair (low: 10, high: -38, index: 120)
[<c0405876>] dump_trace+0x69/0x1af
[<c04059d4>] show_trace_log_lvl+0x18/0x2c
[<c0405f83>] show_trace+0xf/0x11
[<c0406080>] dump_stack+0x15/0x17
[<e0a0f6f6>] bcm43xx_phy_lo_adjust+0x1e2/0x221 [bcm43xx]
[<e0a11309>] bcm43xx_phy_initb6+0x699/0x7c9 [bcm43xx]
[<e0a114e3>] bcm43xx_phy_initg+0xaa/0xd2c [bcm43xx]
[<e0a13186>] bcm43xx_phy_init+0x5e5/0x603 [bcm43xx]
[<e0a03dff>] bcm43xx_chip_init+0x738/0xa31 [bcm43xx]
[<e0a0550e>] wireless_core_up+0x1ad/0x69f [bcm43xx]
[<e0a05d7a>] bcm43xx_select_wireless_core+0x37a/0x4c9 [bcm43xx]
[<e0a05fb9>] bcm43xx_init_board+0x47/0x11e [bcm43xx]
[<c05b1736>] dev_open+0x2b/0x62
[<c05b015a>] dev_change_flags+0x46/0xe3
[<c05ec0e2>] devinet_ioctl+0x250/0x553
[<c05a7036>] sock_ioctl+0x19b/0x1bf
[<c047ae67>] do_ioctl+0x1f/0x63
[<c047b0f5>] vfs_ioctl+0x24a/0x25c
[<c047b153>] sys_ioctl+0x4c/0x65
[<c0404027>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
=======================
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1496:bcm43xx_find_lopair()
bcm43xx: WARNING: Writing invalid LOpair (low: 10, high: -38, index: 120)
[<c0405876>] dump_trace+0x69/0x1af
[<c04059d4>] show_trace_log_lvl+0x18/0x2c
[<c0405f83>] show_trace+0xf/0x11
[<c0406080>] dump_stack+0x15/0x17
[<e0a0f6f6>] bcm43xx_phy_lo_adjust+0x1e2/0x221 [bcm43xx]
[<e0a12011>] bcm43xx_phy_initg+0xbd8/0xd2c [bcm43xx]
[<e0a13186>] bcm43xx_phy_init+0x5e5/0x603 [bcm43xx]
[<e0a03dff>] bcm43xx_chip_init+0x738/0xa31 [bcm43xx]
[<e0a0550e>] wireless_core_up+0x1ad/0x69f [bcm43xx]
[<e0a05d7a>] bcm43xx_select_wireless_core+0x37a/0x4c9 [bcm43xx]
[<e0a05fb9>] bcm43xx_init_board+0x47/0x11e [bcm43xx]
[<c05b1736>] dev_open+0x2b/0x62
[<c05b015a>] dev_change_flags+0x46/0xe3
[<c05ec0e2>] devinet_ioctl+0x250/0x553
[<c05a7036>] sock_ioctl+0x19b/0x1bf
[<c047ae67>] do_ioctl+0x1f/0x63
[<c047b0f5>] vfs_ioctl+0x24a/0x25c
[<c047b153>] sys_ioctl+0x4c/0x65
[<c0404027>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
=======================
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1496:bcm43xx_find_lopair()
bcm43xx: WARNING: Writing invalid LOpair (low: 10, high: -38, index: 120)
[<c0405876>] dump_trace+0x69/0x1af
[<c04059d4>] show_trace_log_lvl+0x18/0x2c
[<c0405f83>] show_trace+0xf/0x11
[<c0406080>] dump_stack+0x15/0x17
[<e0a0f6f6>] bcm43xx_phy_lo_adjust+0x1e2/0x221 [bcm43xx]
[<e0a0f4f2>] bcm43xx_phy_init_pctl+0x202/0x224 [bcm43xx]
[<e0a120f0>] bcm43xx_phy_initg+0xcb7/0xd2c [bcm43xx]
[<e0a13186>] bcm43xx_phy_init+0x5e5/0x603 [bcm43xx]
[<e0a03dff>] bcm43xx_chip_init+0x738/0xa31 [bcm43xx]
[<e0a0550e>] wireless_core_up+0x1ad/0x69f [bcm43xx]
[<e0a05d7a>] bcm43xx_select_wireless_core+0x37a/0x4c9 [bcm43xx]
[<e0a05fb9>] bcm43xx_init_board+0x47/0x11e [bcm43xx]
[<c05b1736>] dev_open+0x2b/0x62
[<c05b015a>] dev_change_flags+0x46/0xe3
[<c05ec0e2>] devinet_ioctl+0x250/0x553
[<c05a7036>] sock_ioctl+0x19b/0x1bf
[<c047ae67>] do_ioctl+0x1f/0x63
[<c047b0f5>] vfs_ioctl+0x24a/0x25c
[<c047b153>] sys_ioctl+0x4c/0x65
[<c0404027>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
=======================
bcm43xx: Chip initialized
bcm43xx: 32-bit DMA initialized
bcm43xx: Keys cleared
bcm43xx: Selected 802.11 core (phytype 2)
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1496:bcm43xx_find_lopair()
bcm43xx: WARNING: Writing invalid LOpair (low: 10, high: -38, index: 120)
[<c0405876>] dump_trace+0x69/0x1af
[<c04059d4>] show_trace_log_lvl+0x18/0x2c
[<c0405f83>] show_trace+0xf/0x11
[<c0406080>] dump_stack+0x15/0x17
[<e0a0f6f6>] bcm43xx_phy_lo_adjust+0x1e2/0x221 [bcm43xx]
[<e0a10534>] bcm43xx_phy_lo_g_measure+0x910/0xaf3 [bcm43xx]
[<e0a06bd6>] bcm43xx_periodic_work_handler+0x144/0x33a [bcm43xx]
[<c042fa48>] run_workqueue+0x83/0xc5
[<c0430340>] worker_thread+0xd9/0x10d
[<c0432807>] kthread+0xc0/0xed
[<c0405447>] kernel_thread_helper+0x7/0x10
DWARF2 unwinder stuck at kernel_thread_helper+0x7/0x10
Leftover inexact backtrace:
=======================
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
ADDRCONF(NETDEV_UP): eth0: link is not ready
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Unable to find matching network after scan!
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Unable to find matching network after scan!
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: generic IE set to dd160050f20101000050f20201000050f20201000050f202
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Queueing Authentication Request to 00:14:c1:03:f9:10
SoftMAC: Cannot associate without being authenticated, requested authentication
SoftMAC: Sent Authentication Request to 00:14:c1:03:f9:10.
SoftMAC: Open Authentication completed with 00:14:c1:03:f9:10
SoftMAC: sent association request!
SoftMAC: associated!
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
SoftMAC: Scanning finished
SoftMAC: sent association request!
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: associated!
ieee80211_crypt: registered algorithm 'TKIP'
bcm43xx: set security called, .active_key = 0, .level = 2, .enabled = 1, .encrypt = 1
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
bcm43xx: set security called, .level = 0, .enabled = 0, .encrypt = 0
SoftMAC: Scanning finished
SoftMAC: Queueing Authentication Request to 00:14:c1:03:f9:10
SoftMAC: Cannot associate without being authenticated, requested authentication
SoftMAC: Sent Authentication Request to 00:14:c1:03:f9:10.
SoftMAC: generic IE set to dd160050f20101000050f20201000050f20201000050f202
SoftMAC: Already associating or associated to 00:14:c1:03:f9:10
SoftMAC: Open Authentication completed with 00:14:c1:03:f9:10
SoftMAC: sent association request!
SoftMAC: associated!
bcm43xx: set security called, .active_key = 0, .level = 2, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
[..]
bcm43xx: set security called, .enabled = 1, .encrypt = 1
eth0: no IPv6 routers present
bcm43xx: set security called, .enabled = 1, .encrypt = 1
[..]
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1
bcm43xx: set security called, .enabled = 1, .encrypt = 1

Again: All iptables chains within the local network are set to ACCEPT. The connection from Window$ on the same machine (dual boot) works perfect.

Greetings
Kai


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]