[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ALSA S/PDIF passthrough woes



My Compaq SR1710NX has an onboard ATI IXP sound card (chipset Realtek ALC658D according to alsamixer) with a coaxial S/PDIF. This system is intended to be a MythTV system with HDTV, standard CATV and DVD.

I've been able to get sound (2 channel PCM) by simply using system- config-soundcard to use the IEC958 device as default. Works great! When encountering AC3, it downmixes to two channels.

However I can't get AC3 or DTS to passthrough no matter what I try. As a simple base case, I tried using mplayer to play a DVD

mplayer -vo xv -ao alsa:device=hw=0.0 -ac hwdts,hwac3, dvd://1

I hear a pop and then nothing. aplay -l looks like this:
**** List of PLAYBACK Hardware Devices ****
card 0: IXP [ATI IXP], device 0: ATI IXP AC97 [ATI IXP AC97]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: IXP [ATI IXP], device 1: ATI IXP IEC958 [ATI IXP IEC958 (AC97)]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and cat /proc/asound/devices
  2:        : timer
  3:        : sequencer
  4: [ 0- 1]: digital audio playback
  5: [ 0- 0]: digital audio playback
  6: [ 0- 0]: digital audio capture
  7: [ 0]   : control


So I tried both 0.0 and 0.1. With 0.1, mplayer basically halts (maybe 1 frame per minute.. didn't really have the patience to wait). With 0.0 and no -ac component, I get the movie in 2 channel audio.

Any ideas? (BTW, I've tried this with a Turtle Beach Audio Advantage Micro (about the same results) and a Chaintech AV-710 (no sound except from system-config-soundcard))

Thanks,
Tarun

Attachment: PGP.sig
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]