[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Broken local yum repos



I have a local repo for FC5 and FC6. FC6 is new, but FC5 has been
working for a long time. I decided to clean up my scripts and now I've
broken it.

Some of these were updating using rsync, some using lftp. I decided to
make them all use lftp. I made the changes and they appear to be
updating, including the repodata, but now some of them don't work. Even
if I remove the repodata directory and rebuild the repodata manually
they fail. 

For example, if I have my local atrpms enabled I get this when I do a
yum update:

Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 243 kB    00:00
http://192.168.1.2/repomirror/fedora/linux/5/i386/atrpms/i386/stable/repodata/primary.xml.gz: [Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from atrpms-stable: [Errno 256] No more mirrors to try.

By googling I've tried doing "yum clean all" and "yum clean metadata"
but I still get the same thing. I also tried "yum -y remove
yum-fastestmirror" but that is not installed.

Any suggestions on how to fix this? I have similar issues with my FC6
repos.

Thanks,
James


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]