[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ATrpms ffmpeg does not work



On Thu, Jan 11, 2007 at 12:09:06PM -0800, Kam Leo wrote:
> On 1/11/07, Paul Smith <phhs80 gmail com> wrote:
> >On 1/11/07, Kam Leo <kam leo gmail com> wrote:
> >> > I am expericencing the following problem with ATrpms ffmpeg:
> >> >
> >> > $ ffmpeg
> >> > ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined
> >> > symbol: dlclose
> >> > $
> >> >
> >> > Any ideas?
> >>
> >> Axel monitors this list but you will get a faster response if
> >> post your problem on Axel's bug page..
> >
> >Do you mean this
> >
> >http://bugzilla.atrpms.net/
> >
> >Kam?
> >
> 
> Yes.
> 
> P.S. Happy New Year. You, too, Axel.

Thanks, happy new year to you as well.

On Thu, Jan 11, 2007 at 09:39:56PM +0000, Paul Smith wrote:
> Done:
> 
> http://bugzilla.atrpms.net/show_bug.cgi?id=1108

There was already an old bugzilla in there:

http://bugzilla.atrpms.net/show_bug.cgi?id=1033

In a nutshell: It looks like something chews on some rpms, but it was
never really resolved what it was. This may be prelink or perhaps
another repo installing stuff over the ATrpms' bits. When the users
identified the manipulated package (in their case x264 and
subpackages) and reinstalled them from ATrpms the problem was fixed.

E.g. try rpm -q and rpm -V on all affected parts and reinstall the
rpms that show modifications. If you identify what is was (prelinking,
other repo overwriting ATrpms' packages etc) please feed me back!

See especially http://bugzilla.atrpms.net/show_bug.cgi?id=1033#c11 and
http://bugzilla.atrpms.net/show_bug.cgi?id=1033#c14

| | 
| | Thomas, it looks like indeed the same bug as Dave's, e.g. your "bad"
| | machine does not reference libdl.so.2 at all (as well as some other
| | X11 libs).
| | 
| | The size differences of /lib/libdl-2.4.so may really be due to
| | prelinking. On a fresh install w/o prelinking I see 14652 bytes, on a
| | system w/ prelinking it's 16436, just like your two systems.
| | 
| | prelinking may cause problems, I hadn't thought about it. It usually
| | happens if you install packages while the prelinking is running
| | (prelinking usually runs at 4:00 in the night, but if the PC was off
| | and you use anacron it may run at more regular times, too). The
| | easiest way to fix it is to reinstall the package. rpm -V on the
| | packages that may have been eaten by prelinking may give a hint,
| | e.g. rpm -V ffmpeg libavcodec51 could return something along the lines
| | as "has been changed since prelinking" or similar.
| 
| I found it!
| 
| I checked all libs that ffmpeg uses (ldd, rpm -qf <lib>, rpm -V
| <package>) and found this:
| 
| # rpm -V libx264_50
| S.5....T    /usr/lib/libx264.so.50
| 
| I don't know, what exactly the flags mean, but something was different
| here.
| 
| So, I reinstalled libx264_50:
| 
| # rpm --force -Uvh
| /var/lib/smart/packages/libx264_50-svn20060912_2245-1.fc5.at.i386.rpm
| 
| And now ffmpeg works. :-)

-- 
Axel.Thimm at ATrpms.net

Attachment: pgpUhXBOdZSrn.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]