[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: YUM won't give me the correct kernel-devel package



On 1/11/07, Andrew Robinson <awrobinson-ml nc rr com> wrote:
I updated my kernel with 'yum install kernel'. Now I want to install the
  corresponding kernel-devel package. When I run 'uname -a', I get

Linux proteus 2.6.18-1.2869.fc6 #1 SMP Wed Dec 20 14:51:19 EST 2006 i686
athlon i386 GNU/Linux

I assume this means I want the 2.6.18-1.2869.fc6 i686 version of
kernel-devel.

When I run 'yum search kernel-devel', I get the following choices:

kernel-devel.i586  2.6.18-1.2798.fc6  core
kernel-devel.i686  2.6.18-1.2798.fc6  core
kernel-devel.i586  2.6.18-1.2868.fc6  updates
kernel-devel.i686  2.6.18-1.2868.fc6  updates
kernel-devel.i586  2.6.18-1.2849.fc6  updates
kernel-devel.i686  2.6.18-1.2849.fc6  updates
kernel-devel.i586  2.6.18-1.2869.fc6  updates
kernel-devel.i686  2.6.18-1.2869.fc6  updates
kernel-devel.i586  2.6.18-1.2849.fc6  installed
                     ^
                     |
   This tells me that you have the i586 kernel installed. Do "rpm -q
kernel" and
   see if this is not the case. (By the way this is a known bug in
the FC6 installer.)

   You need is to download the i686 kernel, perform a "rpm -ivh
kernel-*.i686.fc6.rpm",
    and reboot with the new kernel.

It looks to me like the one I want is

kernel-devel.i686  2.6.18-1.2869.fc6  updates

When I run 'yum install kernel-devel.i686', the only choice I get is

kernel-devel  i686  2.6.18-1.2798.fc6  core

How do I tell yum that I want the 2869 build version from the updates
repo? I tried several things, but couldn't seem to find the right
combination.

Thanks!

Andrew Robinson



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]