[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot loader problem



On 1/12/07, Mark <msalists gmx net> wrote:
Hello,

I have a problem with booting into FC6:

I had the following installation:
/boot on hda1
/ on md0 (raid1 on hda2 and hda3)
Extended partion on hda4 with only a swap partition as hda5


In the Fedora installation process I selected to install the boot loader in hda1, not on the MBR.


After wiping the entire HD and restoring all partitions using images I had taken from the various partitions, as well as the MBR
(used "dd if=/dev/hda of=backupfile count=1" to backup and the other way around to restore), I get stuck with "GRUB" followed by a
blinking cursor when I try to boot.

Using the SystemRescueCD in order to run grub-install /dev/hda1 does not get me further either.

Running grub-install on /dev/hda instead of /dev/hda1 gets me to the grub prompt, but still not all the way through.

What am I missing?
I think you are missing the

root(hd0,0) command intro grub.

read this that worked for me sometime ago.
http://www.go2linux.org/index.php?option=com_content&task=view&id=32&Itemid=9

Off course I had no raid :)
--
Guillermo Garron
"Linux IS user friendly... It's just selective about who its friends are."
(Using FC6, CentOS4.4 and Ubuntu 6.06)
http://www.go2linux.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]