[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Camera not detected (Manuel Arostegui Ramirez)



El Sábado, 13 de Enero de 2007 17:18, Clodoaldo escribió:

Portmap is running here:

# service --status-all | grep portmap
capi not installed - No such file or directory (2)
cat: /var/run/dhcdbd.pid: No such file or directory
Device not specified in /etc/sysconfig/diskdump
JAVA_EXECUTABLE or HSQLDB_JAR_PATH in '/etc/sysconfig/hsqldb' is set to a non-file.
rndc: connect failed: 127.0.0.1#953: connection refused
Server address not specified in /etc/sysconfig/netdump
portmap (pid 1624) is running...

# ps ax | grep portmap
1624 ? Ss 0:00 portmap
4330 pts/2 R+ 0:00 grep portmap

Restarted:

# service portmap restart
Stopping portmap: [ OK ]
Starting portmap: [ OK ]

Tried gthumb but it hangs when detecting the camera. BTW in the meantime I downloaded the pictures in a Windows machine.
I rebooted the system that I was using and that cleared the portmap problem. I had applied quite a few updates without rebooting so one of the updates was probably causing the weirdness with portmap. Once the system was back up I tried running gphoto2 from the console in run level 3 (without X running). This sort of worked in that the camera was detected and I got some information about the camera but the last meaningful output is:

...
File upload support                 : yes
*** Error (-1: 'Unspecified error') ***

This is followed by instructions for running gphoto2 in debug mode. No pictures are uploaded from the camera. On the other hand, gthumb continues to work as expected.

I am noticing some seliniux messages logged when I activate the camera and gthumb starts:

Jan 13 12:46:59 fubar kernel: audit(1168717619.687:5): avc: denied { dac_override } for pid=2424 comm="pcscd" capability=1 scontext=system_u:system_r:pcscd_t:s0 tcontext=system_u:system_r:pcscd_t:s0 tclass=capability

For a variety of reasons I switched selinux to "permissive" mode. You might give that a try although doing so may only allow you to get to the error message I'm getting with gphoto2. It may allow gthumb to start working. One of my "things to do" is to try to figure out why selinux is spewing "avc: denied" messages on this and my other FC6 box. It started after a policy update a while ago and seems to be getting worse.

Cheers,
Dave

--
Politics, n. Strife of interests masquerading as a contest of principles.
-- Ambrose Bierce


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]