[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5, And FC6 won't shutdown completely



Nigel Henry wrote:
See you with the verdict. :-)

Jim

Ok. Jury's back in with the verdict, sort of. Having done a fresh install of FC5 where FC3 was, I first used Yum to install Apt, and Synaptic, that I'm happier with.

1st problem. The list of kernels on synaptic no longer show the 2. 6.17 kernels, and these were the ones I'm convinced were shutting down completely, prior to updates, or booting with a 2.6.18 kernel. As I can't try the 2.6.17 kernels, I install the 2.6.18 one which is on the list, don't do any updates, and reboot with the 2.6.18 kernel. No acpid started, and it fails to shutdown completely, but as before the original 2.6.15 kernel still shutsdown completely.

You might try to see if the config file for each kernel installed has the smp set to yes or if the kernel is set to no for SMP support. These config files are the config files that the kernel was compiled with, so this will give you information if it was activated on FC5 even though there is an smp version also. For FC6, they should all be set to yes for SMP.


I have to retract my assumtion that this problem was due to updates. I still am convinced that the 2.6.17 kernels were shutting down completely, but it appears that booting with a 2.6.18 kernel appears to make some changes in the system somewhere or other, so that when, later, booting with a 2.6.17 kernel, the 2.6.17 kernel no longer behaves as it used to. Also, and it may be totally unrelated. I notice when booting with a 2.6.18 kernel, I get a system beep when bootup gets to the GDM login.

System beeps were enabled again. I am not sure what FC5 has set for the other configuration options though.

This is not the first time I've seen this sort of kernel problem on the list. A while back someone did a kernel update, and something that did work with an earlier kernel no longer worked. He booted up with the earlier kernel that had worked previously. It may have been the sound card/network card, but I can't remember, but any way after booting with a later kernel, the earlier one didn't behave as it used to, if you can make any sense of that.

So the question is. Is there a mailing list or somewhere that I can find out what big differences there are between the 2.6.17, and the 2.6.18 kernels?

There are several kernel lists when searching for the kernel. The official list I am not sure of.


Also is there anyway of still getting the 2.6.17 kernels, so that I can go through this fiasco again, and try and prove the point?

No one wants to track problems from old versions that are not currently available. Since you have one version that works and the newer versions that work, the developers should be able to work with the current version and the earliest version. You could mention the 2.6.17 versions working correctly and it might be pinned down.


I must say that, at the least, working with computers is "interesting".

Yep, little changes making large effects on the rest of the system are interesting. at-spi was my last amazement during development.

Jim


Nigel.


--
To err is human, but I can REALLY foul things up.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]